Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Trotz Formel KGrößte.....2 gleiche Werte
#1
Hallo zusammen.

Habe eine Tabelle in der ich in einer Spalte Zahlen mit Werten habe.
Nun will ich mit der Formel "Kgrösste"    =KGRÖSSTE($B$2:$B$50;1)

mir die 6 größten anzeigen lassen, doch 4. und 5. größte Zahl ist gleich......warum?

Übersehe ich da irgendetwas?

Gruß
Mike


.xlsx   KGroesste.xlsx (Größe: 11,25 KB / Downloads: 7)
Antwortento top
#2
(13.06.2020, 11:49)MdeJong schrieb: Nun will ich mit der Formel "Kgrösste"    =KGRÖSSTE($B$2:$B$50;1)

mir die 6 größten anzeigen lassen, doch 4. und 5. größte Zahl ist gleich......warum?
Ernsthaft?
Schau dir mal die Werte in Spalte B an. Der Wert 375 kommt eben 2x in deiner Liste vor.
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#3
Hallo, meinst du so..? Also ohne Wiederholungen..? 

Arbeitsblatt mit dem Namen 'Tabelle1 (2)'
DEF
1MaxwertErgebnisDie 6 stäksten Zahlen
2Größter Wert39849
32. Größter3783
43. Größter3766
54. Größter37526
65. Größter37232
76. Größter36711

ZelleFormel
E2=MAX(B:B)
F2=INDEX($A$2:$A$50;VERGLEICH(E2;$B$2:$B$50;0);0)
E3=WENN(MIN(A:A)=MIN(E$2:E2); "";KKLEINSTE(B:B;ZÄHLENWENN(B:B;"<"&E2)))
F3=INDEX($A$2:$A$50;VERGLEICH(E3;$B$2:$B$50;0);0)
Verwendete Systemkomponenten: [Windows (32-bit) NT 6.02] MS Excel 2010
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Jörg

"Wer immer tut, was er schon kann, bleibt immer das, was er schon ist." - Henry Ford
Antwortento top
#4
Hi,

um das herauszufinden, was Du mit Formeln machst, genügt die einfache Sortierfunktion von Excel.

   


@Jörg,

die Lottozahlen fallen manchmal gleich häufig. In F sollten allerdings unterschiedliche Zahlen stehen, daher ist die Formel in F fehlerhaft:

Code:
=AGGREGAT(15;6;$A$2:$A$50/($B$2:$B$50=E2);ZÄHLENWENN($E$1:$E2;E2))


Das bringt die richtige Lösung.
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#5
(13.06.2020, 12:00)shift-del schrieb: Ernsthaft?
Schau dir mal die Werte in Spalte B an. Der Wert 375 kommt eben 2x in deiner Liste vor.
Hallo Shift-del,

das mit dem Wert 375 ist so gewollt.
Das ziel ist trotzdem, das ich die 6 größten Zahlen zu Spalte A mir anzeigen lassen möchte.
Antwortento top
#6
Das macht doch deine Formel, es sei denn, du willst doppelte Werte vermeiden...
Gruß Jörg

"Wer immer tut, was er schon kann, bleibt immer das, was er schon ist." - Henry Ford
Antwortento top
#7
(13.06.2020, 13:29)Jockel schrieb: Hallo, meinst du so..? Also ohne Wiederholungen..? 

Arbeitsblatt mit dem Namen 'Tabelle1 (2)'
DEF
1MaxwertErgebnisDie 6 stäksten Zahlen
2Größter Wert39849
32. Größter3783
43. Größter3766
54. Größter37526
65. Größter37232
76. Größter36711

ZelleFormel
E2=MAX(B:B)
F2=INDEX($A$2:$A$50;VERGLEICH(E2;$B$2:$B$50;0);0)
E3=WENN(MIN(A:A)=MIN(E$2:E2); "";KKLEINSTE(B:B;ZÄHLENWENN(B:B;"<"&E2)))
F3=INDEX($A$2:$A$50;VERGLEICH(E3;$B$2:$B$50;0);0)
Verwendete Systemkomponenten: [Windows (32-bit) NT 6.02] MS Excel 2010
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Ja genau....aber wie packe ich das ganze in einer Formel?    Ich verstehe da grad mal meine?  ;)

(13.06.2020, 13:44)Jockel schrieb: Das macht doch deine Formel, es sei denn, du willst doppelte Werte vermeiden...
Ja ...genaue...doppelte will ich vermeiden!!!

(13.06.2020, 13:44)Jockel schrieb: Das macht doch deine Formel, es sei denn, du willst doppelte Werte vermeiden...
Ja ...genaue...doppelte will ich vermeiden!!!
Antwortento top
#8
(13.06.2020, 13:33)BoskoBiati schrieb: ...
@Jörg,

die Lottozahlen fallen manchmal gleich häufig. In F sollten allerdings unterschiedliche Zahlen stehen, daher ist die Formel in F fehlerhaft:

Code:
=AGGREGAT(15;6;$A$2:$A$50/($B$2:$B$50=E2);ZÄHLENWENN($E$1:$E2;E2))

Das bringt die richtige Lösung.

Hi Edgar, ich habe doch dieselben Ergebnisse... ceteris paribus... 

Arbeitsblatt mit dem Namen 'Tabelle1 (2)'
FGH
249491
3331
4661
526261
632321
711111

ZelleFormel
F2=INDEX($A$2:$A$50;VERGLEICH(E2;$B$2:$B$50;0);0)
G2=AGGREGAT(15;6;$A$2:$A$50/($B$2:$B$50=E2);ZÄHLENWENN($E$1:$E2;E2))
H2=DELTA(F2;G2)
Verwendete Systemkomponenten: [Windows (32-bit) NT 6.02] MS Excel 2010
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Jörg

"Wer immer tut, was er schon kann, bleibt immer das, was er schon ist." - Henry Ford
Antwortento top
#9
Zitat:Ja ...genaue...doppelte will ich vermeiden!!!



Und das kann man nicht in den Eingangspost schreiben? Warum erfahren die Helfer die genaue Aufgabe immer erst durch Nachfragen?
Antwortento top
#10
(13.06.2020, 13:49)Jockel schrieb: Hi Edgar, ich habe doch dieselben Ergebnisse... ceteris paribus... 

Arbeitsblatt mit dem Namen 'Tabelle1 (2)'
FGH
249491
3331
4661
526261
632321
711111

ZelleFormel
F2=INDEX($A$2:$A$50;VERGLEICH(E2;$B$2:$B$50;0);0)
G2=AGGREGAT(15;6;$A$2:$A$50/($B$2:$B$50=E2);ZÄHLENWENN($E$1:$E2;E2))
H2=DELTA(F2;G2)
Verwendete Systemkomponenten: [Windows (32-bit) NT 6.02] MS Excel 2010
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Hallo Boskobiati,   =AGGREGAT(15;6;$A$2:$A$50/($B$2:$B$50=E2);ZÄHLENWENN($E$1:$E2;E2))   ......diese löst mein Problem....danke. Dann ist meine Formel =KGRÖSSTE($B$2:$B$50;1)
für die Spalte E korrekt und sie kann so bleiben?

Gruß  Mike
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste