Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Das Update ist abgeschlossen, Ihr könnt unser Forum jetzt wieder wie gewohnt nutzen. Eventuelle Bugs und Auffälligkeiten postet Ihr bitte im entsprechenden Forum im Bereich Forumstechnik. x


Transformation eines Tabellenblattes
#1
Hallo liebe Community,

nachdem ich drei Tage vergeblich versucht habe mein Problem selbst zu lösen wende ich mich verzweifelt an Euch.

Als Ausgangslage habe ich ein Tabellenblatt mit drei Spalten (Vertragsnummer, Fondsname, Fondswert).
Jede Vertragsnummer gibt es unterschiedlich oft (1-6 mal), da jeder Vertrag eine andere Anzahl an Fonds besitzt.
Ich benötige in einem anderen Tabellenblatt die Ausgabe in einer Zeile. D.h. Spalte A die Vertragsnummer einmalig und dahinter in Spalte B Fondsname 1 in Spalte C Fondswert 1, in Spate D Fondsname 2 in Spalte E Fondswert 2 u.s.w.. 

Kann mir jemand helfen wie ich meine Ausgangstabelle transformieren kann?

Aus meiner Sicht besteht die Schwierigkeit darin, dass in der Ausgangstabelle nicht alle Verträge die gleiche Anzahl an Zeilen haben.

Ich hoffe, dass ich mein Anliegen ausführlich genug geschildert habe.

Vielen Dank für Eure Unterstützung!
Antworten Top
#2
Hi,

hier mal ein Ansatz:


Angehängte Dateien
.xlsx   Transformation.xlsx (Größe: 10,15 KB / Downloads: 9)
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antworten Top
#3
@BoskoBiati: deine Formeln scheinen mit etwas umständlich.

Statt
=FILTER(EINDEUTIG(A2:A8;0);1)
sollte doch
=EINDEUTIG(A2:A8)
völlig ausreichen.

Und statt
=WENNFEHLER(INDEX($B:$C;AGGREGAT(15;6;ZEILE($A1:$A15)/($A1:$A15=$E2);KÜRZEN((SPALTE(A1)-1)/2+1;));REST(SPALTE(A1)-1;2)+1);"")
würde ich
=ZUZEILE(FILTER($B$2:$C$8;$A$2:$A$8=E2))
empfehlen.
Gruß,
Helmut

Win10 - Office365 / MacOS - Office365
Antworten Top
#4
Hallo Helmut,

Du hast recht, aber ich bin mit diesen ganzen neuen Funktionen nicht vertraut und werde die meisten auch nie brauchen.
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antworten Top
#5
Hallo PQ-M-Fan's

hier mal 1e Power Query Lösung.

Gruß von Luschi
aus klein-Paris


Angehängte Dateien
.xlsx   Transformation_1.xlsx (Größe: 21,22 KB / Downloads: 4)
[-] Folgende(r) 1 Nutzer sagt Danke an Luschi für diesen Beitrag:
  • schauan
Antworten Top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste