Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Top Liste erstellen
#1
Moin zusammen,

ich wollte mmir eine Top 20 Liste erstellen aber leider scheind es schwieriger als ich dachte.
 Ich habe eine Spalte mit Sorten und mit m² nun möchte ich gerne die Sorte mit den meisten m² auf Top eins usw.
Die Sorte kann öffters erscheinen als muss vorab gerechnet werden wieviel die Sorte an m² hat.

Sprich
G_BC 31 mit 100m²
G_BC 31 mit 200m²
G_BC 50 mit 200m²
G_BC 60 mit 100m²

Ergebniss
Top 1 = G_BC31 = 300m²
Top 2 = G_BC50 = 200 m²
Top 3 = G_BC60 = 100 m²

im Anhang habe ich auch eine Test Tab.

Danke und Gruß Jürgen


Angehängte Dateien
.xlsx   Mappe1.xlsx (Größe: 11,92 KB / Downloads: 2)
Antwortento top
#2
Hallo Jürgen,

das ist ein klassischer Fall für eine Pivotauswertung. Dazu bedarf es nur weniger Mausklicks, und Du hast genau genau das was Du anstrebst.

Siehe beigefügte Datei.

Zum Vergleich nachfolgend noch eine Formelauswertung,. Diese müsste ansich noch etwas komplizierter definiert werden, wenn nicht wie im vorliegenden Beispiel, die Summenwerte nicht alle verschieden wären. Formel nach unten ziehend kopieren.

Die Pivotauswertung (oder alternativ eine PowerQuery-Lösung über Daten Abrufen und transformieren) ist der Formellösung auf jeden Fall vorzuziehen:

Arbeitsblatt mit dem Namen 'Sorten'
ABCDEFGHIJ
1DatenPivotauswertungFormelauswertung
2SortenSorteSumme von m²TopSorteSumme m²
3G_BC32725,20G_EB3485448,21G_EB3485448,2
4G_BC324527,60G_EB1275875,72G_EB1275875,7
5G_BC32784,00G_BC3271910,83G_BC3271910,8
6G_BC32560,00G_EB3067815,44G_EB3067815,4
7G_BC321960,00G_B78_28588367482,05G_B78_28588367482,0
8G_BC30949,20G_BC3060715,56G_BC3060715,5
9G_BC301464,40G_BC6132985,87G_BC6132985,8
10G_BC301092,00G_B1330272,68G_B1330272,6
11G_BC30974,40G_BC1124209,89G_BC1124209,8
12G_BC30974,40G_B3120675,410G_B3120675,4
13G_BC30974,40G_BC69120238,411G_BC69120238,4
14G_BC30974,40G_B13_H13865,012G_B13_H13865,0
15G_BC301005,20G_BC11_H11527,613G_BC11_H11527,6
16G_BC30551,60G_EB6410812,514G_EB6410812,5
17G_BC301176,00G_EB609697,115G_EB609697,1
18G_BC301626,80G_EB357285,616G_EB357285,6
19G_BC56887,80G_B31_H6210,017G_B31_H6210,0
20G_BC56230,00G_BC566205,418G_BC566205,4
21G_BC562686,40G_BC124169,219G_BC124169,2
22G_BC56411,70G_BC32_H3355,720G_BC32_H3355,7
23G_BC561989,50
24G_BC32_H3355,70
25G_BC32713,00

ZelleFormel
I3=WENN(H3="";"";INDEX(B:B;2+VERGLEICH(J3;INDEX(SUMMEWENN(B$3:B$222;B$3:B$222;C$3:C$222););0)))
J3=WENN(H3="";"";AGGREGAT(14;6;SUMMEWENN(B$3:B$222;B$3:B$222;C$3:C$222)/(SUMMEWENN(B$3:B$222;B$3:B$222;C$3:C$222)<WENN(ZEILE()=3;9^9;J2));1))
Verwendete Systemkomponenten: [Windows (32-bit) NT 6.02] MS Excel 2010
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg


Angehängte Dateien
.xlsx   CEF_Jürgen.xlsx (Größe: 17,3 KB / Downloads: 5)
Gruß Werner
.. , - ...
[-] Folgende(r) 1 Benutzer sagt Danke an neopa für diesen Beitrag:
  • JürgenRa
Antwortento top
#3
Hi,

da hast du Recht, dennoch benötige ich diese berechnung weil sie ein Teil îst die ich für ein Dynamisches Dashboard benötige.
Antwortento top
#4
Hi,

auch mit Pivot kann man Daten erzeugen, die auf einem dynamischen Dashboard angezeigt werden können.

Gruß Ralf
[-] Folgende(r) 1 Benutzer sagt Danke an Rabe für diesen Beitrag:
  • JürgenRa
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste