Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Text in Zahl umwandeln
#1
Hallo zusammen,

bekomme regelmäßig große Datensätze. Leider sind diese als Text formatiert. Das Umwandeln in eine Zahl wäre kein Problem, allerdings enthalten eine Datensätze Sonderzeichen wie z. B. Punkte und Bindestriche, diese werden leider entfernt, wenn ich den Text formatiere.

Gibt es einen Trick wie die Sonderzeichen beibehalten werden und gleichzeitig der Text in eine Zahl formatiert wird?

Vielen Dank für die Mühe!


Angehängte Dateien
.xlsb   Text in Zahl umwandeln.XLSB (Größe: 244,14 KB / Downloads: 10)
Antworten Top
#2
Hi,

B1:
=WENNFEHLER(--A1;A1)

und runterkopieren.
Antworten Top
#3
Hi Boris,

vielen Dank für die Formel! Leider eliminiert die auch die Sonderzeichen.
Antworten Top
#4
Ein Zahl kan kein Sonderzeichen enthalten.
Wass willt du ? Beispiele, bitte.
Zum übersetzen von Excel Formeln:

http://dolf.trieschnigg.nl/excel/index.p...gids=en+de
Antworten Top
#5
Meine z. B. diese Nummern:

1087.298.364
1087.298.365
S671.090.312
5961.303.474
S671.090.170
5961.307.148
S671.090.255
AA01.500.001
1068.298.062
5961.303.275
1068.298.083
1071.298.033
5961.303.116
5961.308.412
1071.298.038
5961.304.069
Antworten Top
#6
Das sind keine. Das sind Texte und werden sie immer bleiben.

1087.298.364 kan man schreiben als Zahl: 1087298364 und formattieren als 1087.298.364
Zum übersetzen von Excel Formeln:

http://dolf.trieschnigg.nl/excel/index.p...gids=en+de
Antworten Top
#7
Hab's mir leider schon fast gedacht. Dennoch Danke!
Antworten Top
#8
Moin,

aber wo ist denn das Problem? Wenn die Zahlenkombinationen als Text importiert werden, sind doch alle Informationen vollständig enthalten. Warum willst du Zahlen draus machen?

Viele Grüße 
derHöpp
Antworten Top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste