Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Text finden und Wert daneben als Referenz für Berechnung verwenden
#1
Hallo zusammen,
ich benötige Hilfe bei einer Excel Formel und hoffe, dass ihr mir helfen könnt.

Angehängt könnt ihr sehen was mein Problem ist.
Spalten A und B sind vorhanden.
Ein "Datenpaket" besteht aus einem "A" in Spalte A und einem oder mehreren "B".
Ich muss nun in Spalte C die beschriebene Berechnung durchführen.

Wenn in Spalte A ein "A" vorkommt, dann ist der Wert in der Zelle rechts neben dem "A" die Referenz für die Berechnung.
Wenn in Spalte A ein "B" vorkommt, dann soll die oben gefundene Referenz mit dem Wert rechts neben dem "B" zur Berechnung verwendet werden.

Wie viele "B" auf das A folgen ist nicht bekannt.
Weiss jemand wie die Formel dafür aussehen muss?

Eine andere Frage ist, ob jemand weiss, wie man eine bedingte Formatierung erstellen kann, welche jedes "Datenpaket", also alle zusammengehörigen "A" und "B" samt der zugehörigen Zeilen mit einem dicken Rahmen umrahmt?

Vielen Dank euch im Voraus für eure Hilfe!
Gruss kally


Angehängte Dateien Thumbnail(s)
   
Antwortento top
#2
Hallöchen,

hier mal ein Ansatz.

Arbeitsblatt mit dem Namen 'Tabelle2'
ABC
1A1
2B44
3A2
4B510
5B612
6A3
7B721
8B824

ZelleFormel
C1=WENN(A1="B";VERWEIS(2;1/($A$1:A1="A");$B$1:B1)*B1;"")
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.2) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#3
Hallo schauan,

vielen Dank, das hat so funktioniert! 17
Ich wollte die Formel noch auf eine andere Berechnung ausweiten, das will aber einfach nicht klappen.
Kannst du evtl. noch mal drüberschauen?

Vielen Dank dir im Voraus.
Gruss kally


Angehängte Dateien Thumbnail(s)
   
Antwortento top
#4
Hallöchen,

da musst Du doch nur aus den 3 B in der Formel 3 C machen?
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#5
(21.10.2020, 14:20)schauan schrieb: Hallöchen,

da musst Du doch nur aus den 3 B in der Formel 3 C machen?

Du hast Recht, da hat was mit meiner Rechnung nicht gestimmt :D
Nun noch eine Frage:
Gibt es eine max. Anzahl an Argumenten die man einer Funktion hinzufügen kann? Ich bekomme nämlich eine solche Fehlermeldung.
Ich möchte schlicht das Ergebnis aus Spalte E mit -1 multiplizieren wenn der gleichen Zeile, jedoch z.B. in der neu hinzugefügten Spalte A ein "x" auftritt.
Vielen Dank dir im Voraus!
Gruss kally


Angehängte Dateien Thumbnail(s)
   
Antwortento top
#6
Moin,

lad mal bitte anstelle der Bildchen eine Beispieldatei hoch. Ich habe keine Lust, nach Bildern oder Beschreibungen selbst eine zu erstellen, um Ideen darin zu testen. Sad
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#7
Hallöchen,

im Prinzip kannst Du der Formel eine weitere Berechnung hinzufügen. Die Zahl neben dem A bekommst Du ja mit diesem Formelteil:

VERWEIS(2;1/(B1:B1000="A");C1:C1000)

Wenn Du statt x und y dann -1 und 1 schreibst könntest Du auch die Zahl vor der Spalte mit dem A entnehmen und damit multiplizieren. Hier mal anhand des vorherigen Beispiels von mir

Arbeitsblatt mit dem Namen 'Tabelle2'
ABCD
11A1
2B44
3-1A2
4B5-10
5B6-12
61A3
7B721
8B824

ZelleFormel
D1=WENNFEHLER(WENN(B1="B";VERWEIS(2;1/($B$1:B1="A");$C$1:C1)*C1;"")*VERWEIS(2;1/($B$1:B1="A");$A$1:A1);"")
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.2) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste