Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Teilsuche in Excel, Sverweis funktioniert nicht
#1
Guten Abend zusammen,

ich bin auf der Suche nach jemanden, der mir bei folgender Aufgabenstellung helfen kann. Im Idealfall mit einer Formel bzw. Formelverkettung.
Sollte VBA von Nöten sein und sich meinem Problem annehmen sollte, bitte kurz an die Hand nehmen wie/wo ich das dann einfügen und starten kann.

Aufgabenstellung:

Ich habe eine Liste, zig-tausende Zeilen lang - somit auch für manuelle Arbeit unmöglich.


Spalte A+B: Quelldaten welche ich zur Verfügung habe bzw. in denen ich suchen kann.

Spalte D: Diese Daten möchte ich füttern, im Ideallfall mit sverweis, sodass sich D die Daten aus Spalte A+B abgleicht und bei einem Treffer das Ergebnis in Spalte E schreibt.

In meinem Beispiel funktioniert das bei "4136|352" und auch bei "4136|371" da diese exakt so in Spalte A steht.

Bei "4001|150" bzw. "4001|152" funktioniert das nicht mehr, da diese nicht exakt so in einer Zelle stehen.
Wie bekomme ich bei diesen mit der (ich nenne es einfach mal) Teilsuche hin, dass dennoch die Ergebnisse dahinter stehen (also Inhalt aus B1 bzw. B2)

Kann hier jemand helfen?

Danke vorab!


Angehängte Dateien
.xlsx   Beispielliste Forum.xlsx (Größe: 8,17 KB / Downloads: 6)
Antwortento top
#2
Hi,

gibt es in Deinen Spalten A und B nur eindeutige Einträge, oder kommen die Suchstrings evtl. mehrfach in den Spalten vor? Ich denke, dass für Deine Aufgabe PowerQuery eine gute Hilfe wäre. Aber wenn ein Eintrag in mehreren Zellen vorkommt, dann musst Du definieren, was dann passieren soll.

Gruß,
RaiSta
Antwortento top
#3
Hallo D...,

zB. so:

=WENNFEHLER(WENN(D1<>"";INDEX(B:B;VERGLEICH(1;1*(SUCHEN(D1;$A$1:$A$5)>0);0));"");"")
helmut

Für mich ist die Möglichkeit in Excel an Zellen und Bereichen Namen zu vergeben die wichtigste Funktionalität.
Sie macht Formeln und den VBA-code verständlicher. Für Makros gilt die Regel: "Nur über benannte Bereiche auf den Inhalt der Zellen zugreifen."
Und wofür sind Regeln da? Um nachzudenken bevor man sie bricht.





Antwortento top
#4
Hallo,

nein - jeder Datensatz kommt nur einmal vor.

Wobei ein Datensatz immer wiefolgt aufgebaut ist:
8004|357
8004|ABN

Manchmal stehen diese einzeln in der Zelle, manchmal hintereinander: 0603|ASU<>0603|ASZ<>0603|AXD

(16.10.2020, 01:09)Ego schrieb: Hallo D...,

zB. so:

=WENNFEHLER(WENN(D1<>"";INDEX(B:B;VERGLEICH(1;1*(SUCHEN(D1;$A$1:$A$5)>0);0));"");"")

In welche Zelle muss das rein?
Wenn ich das in E1 einfüge und nach die Formel nach unten ziehe - passiert nichts.

Was muss in der Formel noch von mir ergänzt werden?
Antwortento top
#5
Hallo D...,

bei mir schon (siehe Anlage).


Angehängte Dateien
.xlsx   Beispielliste Forum-1.xlsx (Größe: 9,53 KB / Downloads: 3)
helmut

Für mich ist die Möglichkeit in Excel an Zellen und Bereichen Namen zu vergeben die wichtigste Funktionalität.
Sie macht Formeln und den VBA-code verständlicher. Für Makros gilt die Regel: "Nur über benannte Bereiche auf den Inhalt der Zellen zugreifen."
Und wofür sind Regeln da? Um nachzudenken bevor man sie bricht.





Antwortento top
#6
Hallo DTM_

wenn du das Suchkriterium beim SVWERWEIS mit * verwendest, sollte es auch funktionieren.

Formel in E1:
=SVERWEIS("*"&D1&"*";$A$1:$B$4;2;0)

Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDE
14001|150<>4136|34077654001|1507765
24136|339<>4001|15277694001|1527769
34136|35295034136|3529503
44136|371118994136|37111899

ZelleFormel
E1=SVERWEIS("*"&D1&"*";$A$1:$B$4;2;0)
Verwendete Systemkomponenten: [Windows (32-bit) NT 6.02] MS Excel 2010
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg

Die Formel von Helmut ist eine Matrixformel
=> Eingabe mit Strg+Shift+Enter

Gruß
Fred
[-] Folgende(r) 1 Benutzer sagt Danke an Fred11 für diesen Beitrag:
  • DTM_
Antwortento top
#7
Thumbs Up 
Hallo Fred11,

18 vielen, vielen Dank!

Das kann sogar ich umsetzen Smile
Hat funktioniert! 

Merci an ALLE!
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste