Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Tabellen zusammenfügen mit Bedingungen
#1
Hallo Gemeinschaft,

ich versuche derzeit zwei Tabellen zusammenzuführen.

Tabelle 1 ist folgendermaßen aufgebaut:

ID  Jahr Wert1

01   1995  2
01   1997  3
02   1995   4
02   1997  5 
03   1995   6
03    1997  7

Tabelle 2 

ID Jahr Wert2 Wert3

01   1995  5     3 
01   1997  7    2 
02   1995   8   1
02   1997  9   4
03   1995   2  1
03    1997  1  5

Ich möchte nun zu Tabelle 2 den Wert 1 hinzufügen, aber nur wenn ID und Jahr in Tabelle 1 und 2 übereinstimmen.

z,B,

ID Jahr Wert1  Wert2  Wert3
01 1995  2       5        3

Welche Formeln benötige ich hierfür? Könnte mir jmd. Hinweise geben? Die Tabellen befinden sich in einer Arbeitsmappe, jedoch in verschiedenen Blättern. 

Viele Grüße,
Kehricht
Antwortento top
#2
Hi,

füge in Tabelle 1 eine Hilfsspalte ein und hole dir die Daten dann per SVERWEIS().

Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDEFGHIJ
1ID JahrHSWert1IDJahrWert2Wert3Wert1
2
31199511995211995532
41199711997311997723
52199521995421995814
62199721997521997945
73199531995631995216
83199731997731997157

ZelleFormel
C3=A3&B3
J3=SVERWEIS(F3&G3;$C$3:$D$8;2;0)
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.2) erstellt. ©Gerd alias Bamberg
Gruß Günter
Jeder Fehler erscheint unglaublich dumm,
wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#3
Lieber WillWissen,

herzlichen Dank für deine Hilfe. Mit der "Hilfsspalte" konnte ich das Problem lösen. Vielen Dank!

viel grüße,
kehricht
Antwortento top
#4
Hallöchen,

mal noch ein Ansatz ohne Hilfsspalte:

=VERWEIS(9;1/($A$3:$A$8=E3)/($B$3:$B$8=F3);$C$3:$C$8)
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste