Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Sverweis mit zwei Suchkriterien
#1
Hallo zusammen,

ich bin dabei ein Kostenvergleich zu machen und hänge an einer Aufgabe. :)

In O2 steht z.B. "123"

Mit der Formel: =SVERWEIS(O2;Tabelle3!$A$2:$L$3960;12;FALSCH) finde ich den Wert aus O2 in der Tabelle3!$A$2:$L$3960.
In Tabelle 3 kommt aber der Wert 123 öfters vor in der Spalte A. In der Spalte B habe ich noch zusätzlich 1, oder 2 oder 3 usw. stehen.
Wie muss ich die Formel ändern damit diese in der Tabelle3 Spalte A 123 sucht aber auch 1 oder 2 oder 3 usw. Berücksichtigt und mir den WErt daneben ausgibt?

Ich möchte also in der Spalte A 123 suchen und in der Spalte B nach der 2, also soll mir dann der Wert 888 ausgegeben werden? :)

Tabelle3
 A       B     C
122     1     100
123     1     999
123     2     888
123     3     777
118     1     200

Ich hoffe ich habe das einigermaßen verständlich erklärt...

Vielen Dank im Voraus
LG, Alexandra
Antworten Top
#2
Hola,
Das kann man auch googlen
Gruß,
steve1da
Antworten Top
#3
Moin

FILTER() oder SUMMEWENNS().
Wir sehen uns!
... Detlef

Meine Beiträge können Ironie oder Sarkasmus enthalten.

Antworten Top
#4
Hallo zusammen,

DANKE!!! ich habe tatsächlich mit Goo.. eine passende Formel gefunden und es funktioniert, sieht wie folgt aus:

=WENNFEHLER(SVERWEIS($T2&$AD2;WAHL({1.2};'IP2023'!$A$6:$A$2011&'IP2023'!$B$6:$B$2011;'IP2023'!$C$6:$C$2011);2;0);"")

Die Ausgabe aus Spalte C wird ausgespuckt! :)

Ich würde gerne das Ergebnis aus IP2023'!$C$6:$C$2011 flexibel gestalten, so dass die Ausgabespalte mit dieser Formel gezogen wird  =WECHSELN(ADRESSE(1;VERGLEICH(R2;'IP2023'!$A$3:$S$3;0);4);"1";"").
Weiß aber nicht wie ich das einbauen soll? Kann jemand helfen?

Vielen Dank
LG, Alexandra
Antworten Top
#5
Eine Beispieldatei wäre hilfreich.
Antworten Top
#6
Hi,

Zitat:Ich würde gerne das Ergebnis aus IP2023'!$C$6:$C$2011 flexibel gestalten, so dass die Ausgabespalte mit dieser Formel gezogen wird  =WECHSELN(ADRESSE(1;VERGLEICH(R2;'IP2023'!$A$3:$S$3;0);4);"1";"").
Weiß aber nicht wie ich das einbauen soll? Kann jemand helfen?

Das geht grundsätzlich mit INDIREKT(). Allerdings ist es meist nicht erforderlich, den Spaltenbuchstaben zu ermitteln (mit Deiner WECHSELN-ADRESSE-Formel). Da gibt es sicher einfachere Möglichkeiten.
Deine jetzt verwendete SVERWEIS-Formel ist sicher auch optimierbar.
Wie Steve schon schrieb: Zeig mal bitte eine Beispielmappe.
Antworten Top
#7
Hallo Boris, Hallo Steve,

Beispieldatei anbei, ich habe die Daten um die es geht rot markiert. :)

Danke & LG, Alexandra
.xlsx   Test - Kopie.xlsx (Größe: 21,12 KB / Downloads: 5)
Antworten Top
#8
Hi,

=INDEX('IP2023'!$C$6:$S$20;VERGLEICH(T2&AD2;'IP2023'!$A$6:$A$20&'IP2023'!$B$6:$B$20;0);VERGLEICH(R2;'IP2023'!$C$3:$S$3;0))
Antworten Top
#9
Hallo Boris,


suuuuuper, es funktioniert perfekt! Vielen vielen Dank!!!

Nur Interessehalber meine Formel mit dem Sverweis hätte man auch mit flexible Spalten anpassen können? Wenn ja wie?

Vielen DANK!!!

LG, Alexandra
Antworten Top
#10
Hi,

Zitat:Nur Interessehalber meine Formel mit dem Sverweis hätte man auch mit flexible Spalten anpassen können? Wenn ja wie?

Dieses WAHL-Konstruktion für den SVERWEIS ist eigentlich mehr eine Spielerei als eine ernst gemeinte Alternative. Vergiss sie einfach Wink
Antworten Top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste