Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Sverweis mit dynamischen Spaltenindex
#1
Hallo zusammen,

ich bin schier am verzweifeln. Hoffe Ihr könnt mir helfen.

Ich habe folgendes vor:

Ich möchte in einer Datei eine Zahl immer aktuell halten (zuletzt verfügbarer Wert) und dies aus einer anderen Excel herauslesen.

Ansatz war natürlich der Sverweis. Soweit so gut. Such ich gem. Beispiel ABC und finde die Zeile. Easy.
Aber ich möchte ja einen dynamischen Spaltenindex im Sverweis, der immer den letzten Wert größer Null in der Zeile nimmt.
Hier in dem Beispiel die 6.  Beim SVERWEIS nach ABX wäre das dann 4 aus Q1/19 und nicht 6 aus Q2/19
Bei ABZ dann natürlich der gesuchte Wert 5 und nicht 6 dann..

   


=SVERWEIS(A14;Dateiname.xlsx!$A$2:$J$74;VERWEIS(9999999999;Dateiname.xlsx!$58:$58;SPALTE(Dateiname.xlsx!$58:$58));FALSCH)

Nur für die Logik. Dateiname und Zielenbeschriftungen nicht auf das Beispielbild angepasst.

Besten Dank,

Daniel
Antwortento top
#2
Hallo,
wann wird hier der Letzte begreifen das man mit Bildern in 99% aller Fälle nichts anfangen kann.
Gruß Armin
Ich arbeite mit WIN10 64bit und Excel 19 64bit


Antwortento top
#3
Moin

Wie immer liegt es an der richtigen Datenstruktur.
Für eine nach Datum aufsteigend sortierte Liste:
Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDEFG
1KategorieDatumWertABX4
2ABC01.10.20175ABZ5
3ABC01.01.20186
4ABC01.04.20186
5ABC01.07.20186
6ABC01.10.20186
7ABC01.01.20196
8ABC01.04.20196
9ABX01.01.20184
10ABX01.04.20184
11ABX01.07.20184
12ABX01.10.20184
13ABX01.01.20194
14ABZ01.10.20184
15ABZ01.01.20195

ZelleFormel
G1=INDEX($C$2:$C$15;AGGREGAT(14;6;ZEILE($A$2:$A$15)/($A$2:$A$15=F1);1)-1)
Verwendete Systemkomponenten: [Windows (32-bit) NT 6.01] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.2) erstellt. ©Gerd alias Bamberg
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste