Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Sverweis bei Leerer Zelle trotzdem ausgeben.
#1
Photo 
Guten Abend. 

Ich habe eine Datenliste mit aufsteigenden werten . 
Spalte a sieht ungefähr so aus

1.1 1.2 1.3.....
Eine leehrzelle 
Danach 2.1 2.2 2.3
Leerzeile
3.1 3.2 3.3

Spalte b stehen Wörter
Spalte c dazugehörige Werte zu den wörtern. 

Auf einem gesonderten Blatt habe ich ein Formulare, die ich später irgendwie als PDF speichern möchte. In der ersten Spalte hole ich mir die Nummern von Blatt mit


Zitat:=WENNFEHLER(WENN(INDEX(tab_Planwerte[Raum Nr.];AGGREGAT(15;6;(ZEILE(tab_Planwerte[WE Nr])-1)/(FINDEN($C$13;tab_Planwerte[WE Nr];1)>0);ZEILE()-18);1)=0;"";INDEX(tab_Planwerte[Raum Nr.];AGGREGAT(15;6;(ZEILE(tab_Planwerte[WE Nr])-1)/(FINDEN($C$13;tab_Planwerte[WE Nr];1)>0);ZEILE()-18);1));"")


In der 2. Spalte wollte ich mir mit sverweis die Werte aus blatt1 Spalte 2 holen.
Das klappt.

Zitat:=SVERWEIS(A19;tab_Planwerte[[Raum Nr.]:[zeile]];2;FALSCH)

Die Werte 1.1 1.2 1.3..... , 2.1 2.2 2.3 etc.. Sollen auf separate tabellenblätter, da wie vorhin schon erwähnt pdf Formulare daraus entstehen sollen.


Zu meinem Problem. in blatt1 spalte1 die lehrzelle, gehört zu den Werten darüber. Hat immer die selbe Bezeichnung.

Wenn ich das auf blatt2 Spalte 2 runter kopiere... passiert das was in dem Screenshot zu sehen ist.... wie kann ich das ändern.

Puh. Das war jetzt kompliziert zu erklären, ich hoffe das hilft euch

Vielen Dank schon mal


Angehängte Dateien Thumbnail(s)
   

.xlsx   Mappe (9).xlsx (Größe: 9,64 KB / Downloads: 14)
Antwortento top
#2
Ich hab mir mittlerweile selber geholfen. Ich habe aggregat benutzt. Das wollte ich zwar nicht. Weil ich das Gefühl hatte das meine arbeitsmappe durch aggregat langsamer wird.
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste