Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Summe von Zellen, wenn Zellen in anderer Spalte übereinstimmen
#1
Hallo,

ich habe eine große Datei in der ich Summen von Zellen aller Zeilen einer Spalte ermitteln will, bei der die Werte aller Zeilen einer anderen Spalte dieser Zeile übereinstimmen. Siehe Anhänge.


Z.B. wenn in Spalte 1 354460 enthalten ist, möchte ich die Summe aller Zellen der letzten Spalte in den gleichen Zeilen erhalten.



Ich habe mir schon einen Wolf gesucht über Google. Vielleicht kann mir hier jemand schneller helfen. Herzlichen Dank erstmal.


Angehängte Dateien Thumbnail(s)
   

.xlsx   Beispieldatei.xlsx (Größe: 9,4 KB / Downloads: 6)
Antwortento top
#2
=SUMMENPRODUKT((A1:A9=B1:B9)*A1:A9) summiert A, wo A=B
Antwortento top
#3
Moin,

SUMMEWENN() hilft hier.
Code:
=SUMMEWENN($A$1:$A$12;354460;$K$1:$K$12)
Gruß Günter
Jeder Fehler erscheint unglaublich dumm,
wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#4
Danke für die schnelle Antwort. Mit der Formel ist  das Ergebnis aber 0 statt der richtigen -8.493,00.

Das Problem bei dieser Formel ist aber, dass ich mit der Konstanten 354460 arbeiten müsste, statt einen Vergleich über eine Formel zu machen. Denn für die Konstante ist die Datenmenge zu groß.

(19.06.2020, 12:50)LCohen schrieb: =SUMMENPRODUKT((A1:A9=B1:B9)*A1:A9) summiert A, wo A=B

Ich brauche aber Vergleich aller Zellen in A und dann die Summe aller Werte der Zellen der Spalte K, in denen die Werte in Spalte A gleich sind.
Antwortento top
#5
Hallo mit einer richtigen Tabelle (Also mit Überschriften und als Tabelle formatiert {Str+T}) ist das mit Power Query - gerade bei größeren Datenmengen ein Kinderspiel... oder die allseits beliebt Funktion MEHRFACHOPERATION()...
Gruß Jörg

"Wer immer tut, was er schon kann, bleibt immer das, was er schon ist." - Henry Ford
Antwortento top
#6
Hi,


Zitat:Danke für die schnelle Antwort. Mit der Formel ist  das Ergebnis aber 0 statt der richtigen -8.493,00.
dann machst du irgendwo einen Fehler!


Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDEFGHIJKL
1354450SSNTAADR6190365982019203-210502119619A06.01.202003.04.202050-1.200,80-8493
2354460SSNTAADR6190807845446500872619A09.10.202019.12.201950-7.685,00
3354460SSNTAADR6190807845446501180619A05.09.202012.02.202050-6.148,00
4354460SSNTAADR6190807845446501181619A06.01.202012.02.202050-1.537,00
5354460SSNTAADR6190807845446501182619A12.02.202012.02.2020406.148,00
6354460SSNTAADR6190807845446501207619A12.02.202012.02.2020401.537,00
7354460SSNTAADR6190807842019204-211501632619A05.09.202017.03.202050-6.794,40
8354460SSNTAADR6190807842019204-211501633619A06.01.202017.03.202050-1.698,60
9354460SSNTAADR6190807842019204-211501634619A17.03.202017.03.2020406.148,00
10354460SSNTAADR6190807842019204-211501635619A17.03.202017.03.2020401.537,00
11354470SSNTAADR6190807935447500873619A16.10.202019.12.201950-6.383,00
12354470SSNTAADR6190807935447501173619A12.02.202012.02.2020401.276,60

ZelleFormel
L1=SUMMEWENN($A$1:$A$12;354460;$K$1:$K$12)
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg

Anstelle der festen Verdrahtung in der Formel kannst du auch mit einem Zellbezug arbeiten.

Oder du erststellst eine Pivottabelle. Das Bild zeigt dir, wie sie aussieht.

   
Gruß Günter
Jeder Fehler erscheint unglaublich dumm,
wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#7
Herzlichen Dank! Das erste Mal eine Pivot-Tabelle erstellt. Geiles Tool.... 19
Antwortento top
#8
(19.06.2020, 14:33)jott-te schrieb: Herzlichen Dank! Das erste Mal eine Pivot-Tabelle erstellt. Geiles Tool.... 19

Dann warte mal ab, bist du Power Query (für dich) entdeckt hast...
Gruß Jörg

"Wer immer tut, was er schon kann, bleibt immer das, was er schon ist." - Henry Ford
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste