Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Summe von Potenzen
#1
Guten Abend zusammen

Ich möchte eine variable Anzahl Potenzen einer Zahl aufsummieren und diese mit 12 multiplizieren.

z.Bsp: 

Exponent = 4 (variabel)
Basiszahl = 3 (in Zelle A1)

gewünschtes Resultat: A1^0 + A1^1 + A1^2 + A1^3 + A1^4 = 1 + 3 + 9 + 27 + 81 = 121 * 12 = 1'452

Mit der Formel {=SUMME(POTENZ(A1;{0;1;2;3;4})*12)} kriege ich zwar das richtige Resultat, es gelingt mir aber nicht, die Exponenten variabel abzubilden resp. zu berechnen. 

Hat jemand einen Tipp?

Vielen Dank und freundliche Grüsse

Thomas
Antworten Top
#2
Moin

SEQUENZ(A1) oder für deine alte Möhre ZEILE(INDIREKT("1:"&A1)).
Wir sehen uns!
... Detlef

Meine Beiträge können Ironie oder Sarkasmus enthalten.

[-] Folgende(r) 1 Nutzer sagt Danke an shift-del für diesen Beitrag:
  • Thomas Ramseier
Antworten Top
#3
Für ein aktuelles Excel
PHP-Code:
A1 3
A2 
4
=12*POTENZREIHE(A1;0;1;SEQUENZ(1;A2+1;1;0))
oder
=12*SUMME(POTENZ(A1;SEQUENZ(1;A2+1;0;1))) 
[-] Folgende(r) 1 Nutzer sagt Danke an Warkings für diesen Beitrag:
  • Thomas Ramseier
Antworten Top
#4
Hi,

oder so:

Code:
=SUMME(A1^(ZEILE(A1:INDEX(A:A;A2+1))-1))*12
=SUMME(A1^(ZEILE(A1:INDEX(A:A;A2)));1)*12
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
[-] Folgende(r) 1 Nutzer sagt Danke an BoskoBiati für diesen Beitrag:
  • Thomas Ramseier
Antworten Top
#5
Hallo,

da es sich um eine geometrische Reihe handelt, kann man diese als Formel "umschreiben":
https://de.wikipedia.org/wiki/Geometrische_Reihe

Wenn die Basis in A1 und die Anzahl in A2 steht:
=(1-A1^(A2+1))/(1-A1)*12

Ganz einfach, ohne Matrixformel, Sequenz, Indirekt ...
Gruß
Michael
[-] Folgende(r) 1 Nutzer sagt Danke an Der Steuerfuzzi für diesen Beitrag:
  • Thomas Ramseier
Antworten Top
#6
"Niemand benötigt später im Leben Mathe."
Wir sehen uns!
... Detlef

Meine Beiträge können Ironie oder Sarkasmus enthalten.

Antworten Top
#7
Pffft!
Pfeif auf Mathe!
Dem (sehr) jungen Gauß wurde ja nachgesagt, dass er die Schulaufgabe "Bilde die Summe aller Ganzzahlen von 1 bis 100" in wenigen Sekunden lösen konnte.
Er sagte ja allgemeingültig =(Ende-Anfang+1)/2*(Ende+Anfang) (hier einfacher: 50*101) → 5050
Das macht man "modern" doch einfach mittels Spillformel SEQUENZ:
=SUMME(SEQUENZ(100))
Ihr dürft mich jetzt Carl-Friedrich nennen!  Blush

[/OT]
Gruß Ralf
Gib einem Mann einen Fisch und du ernährst ihn für einen Tag. 
Lehre einen Mann zu fischen und du ernährst ihn für sein Leben. (Konfuzius)
Antworten Top
#8
Ist doch schön, wenn man Schulformeln auch mal einsetzen kann.

Nehmen wir mal 1.000.000 statt 1.000. Wie sieht es da beim Speedvergleich aus?
Antworten Top
#9
Zitat:... da es sich um eine geometrische Reihe handelt ....
Sehr gut gesehen!!  23
Antworten Top
#10
(22.05.2024, 16:58)LCohen schrieb: Nehmen wir mal 1.000.000 statt 1.000. Wie sieht es da beim Speedvergleich aus?

Keine Ahnung, selbst auf meiner alte Möhre "augenblicklich":
ABCD
1vonbisGaußExcel
211000000500.000.500.000500.000.500.000
3178221000001499.842.697.070499.842.697.070

ZelleFormel
C2=(B2-A2+1)/2*(B2+A2)
D2=SUMME(SEQUENZ(B2-A2+1;;A2))
C3=(B3-A3+1)/2*(B3+A3)
D3=SUMME(SEQUENZ(B3-A3+1;;A3))
Gib einem Mann einen Fisch und du ernährst ihn für einen Tag. 
Lehre einen Mann zu fischen und du ernährst ihn für sein Leben. (Konfuzius)
Antworten Top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste