Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Summe über einen Bereich mit Bedingung in anderer Zeile
#1
Hallo,

ich habe euch unten mal eine Beispieldatei eingefügt, in der ich erkläre, was ich vorhabe: 
.xlsx   Beispiel.xlsx (Größe: 15,88 KB / Downloads: 9)
Ich habe eine Tabelle, in der jede Zeile ein Jahr darstellt. In diesen Jahren werden Investitionen getätigt, die im Investitionsjahr eingetragen werden. Dahinter steht auch gleich mit bis wann die Investition abgeschrieben wird und ob die Anlage vorher verschrottet wird. Ist das der Fall, muss ich in den verbleibenden Jahren zwischen Anlagenabgang und regulärem Abschreibungsende die Abschreibungsscheibe der Investition gegenrechnen, da sie nicht mehr anfällt. 
Ich möchte also z.B. im Jahr 2050, dass in den Investitionen der vorangegangenen Jahre geschaut wird, ob das Jahr 2050 zwischen dem Anlagenabgang und regulären Anlagenabgang liegt. Wenn ja, soll die Abschreibung (Afa-Scheibe) dieser Investitionen im Jahr 2050 abgezogen werden.
Gibt es dafür eine Lösung, die ich mit einer Formel umsetzten kann? Makro wäre hier für mich nur der letzte Ausweg, da meine Kollegen das nicht bearbeiten können.

Ich hoffe das war verständlich! 

Vielen Dank!
Antwortento top
#2
Bin selbst drauf gekommen, dass Summewenns die Lösung ist. ich kam nur mit der Eingabe der > und < zusammen mit dem Zellbezug durcheinander:
=SUMMEWENNS($G$4:$G$50;$J$4:$J$50;"<"&$B31;$I$4:$I$50;">"&$B31)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste