Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Summe bilden abhängig vom Wochentag
#1
Servus,
ich würde gerne in meiner Tabelle zur Arbeitszeiterfassung, immer am Sonntag die aufgelaufenen Überstunden abzüglich der evtl. Minuss
tunden errechnen lassen.
Soweit so gut....nur schaff ich es nicht, die richtige Formel zu finden 22
Daher meine Frage/Bitte an Euch, was mahe ich falsch?


Angehängte Dateien
.xlsx   Mappe1.xlsx (Größe: 19,96 KB / Downloads: 14)
Antwortento top
#2
So, die Summenbildung der Ü-Std. habe ich herausgefunden  18
aber.....noch schaff ich es nicht die Minus Stunden abziehen zu lassen...
hier die Formel zur Berechnung der Ü Std.
=WENN(WOCHENTAG(B2;2)=7;SUMMENPRODUKT(($A$2:$A$40=A1)*($J$2:$J$40));"")
Antwortento top
#3
Hi,

mein Vorschlag:
Code:
=WENN(SUMME($J$2:$J$32)>SUMME($K$2:$K$32);TEXT(SUMME($J$2:$J$32)-SUMME($K$2:$K$32);"h:mm")&" plus";TEXT(ABS(SUMME($J$2:$J$32)-SUMME($K$2:$K$32));"h:mm")&" minus")
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.zitate.net
[-] Folgende(r) 1 Benutzer sagt Danke an WillWissen für diesen Beitrag:
  • caos
Antwortento top
#4
Hallo,

mach das doch einfach so:

Januar

EFGHIJKL
1Kommen GehenPauseArbeitszeit NettoSollÜberstundenMinusstundenSaldo
216:0018:000:301:3008:00:006:30
37:0017:000:309:3008:00:0001:30:00
4
55:1417:000:3011:1608:00:0003:16:00
608:00:00
708:00:00-1,73
808:00:00
Formeln der Tabelle
ZelleFormel
L2=WENN(WOCHENTAG(B2;1)=1;SUMME(J$2:J2)-SUMME(K$2:K2);0)
L4=WENN(WOCHENTAG(B4;1)=1;SUMME(J$2:J4)-SUMME(K$2:K4);0)
L5=WENN(WOCHENTAG(B5;1)=1;SUMME(J$2:J5)-SUMME(K$2:K5);0)
L6=WENN(WOCHENTAG(B6;1)=1;SUMME(J$2:J6)-SUMME(K$2:K6);0)
L7=WENN(WOCHENTAG(B7;1)=1;(SUMME(J$2:J7)*24)-(SUMME(K$2:K7)*24);0)

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Viele Grüße
Klaus-Dieter
Der Erfolg hat viele Väter, 
der Misserfolg ist ein Waisenkind
Richard Cobden
Antwortento top
#5
Hallo zusammen,
Vielen Dank für Eure Hilfe.
Ich habe WillWissen Formel genommen, da mir die zusätzluiche Bezeichnung "plus" und "minus" gefällt.
Allerding ergibt sich für mich dadurch ein anderes "problem".

Wie kann ich Text und Zahlen die in einer Zelle stehen, addieren?
Meine Idee auf dem Blatt"Gesamt"

=SUMME(LINKS(B8:B19;FINDEN(" ";B8:B19)-1)*1)

Funktioniert aber nicht  Huh


Angehängte Dateien
.xlsx   Mappe1.xlsx (Größe: 79,59 KB / Downloads: 1)
Antwortento top
#6
Hallo,

wie jedes andere Programm hat auch Excel gewisse Vorgaben, an die man sich halten muss, damit alles so funktioniert, wie es sein soll. Dein konkretes Problem scheint mir zu sein, dass du dich, wie so viele andere an eine Aufgabe gewagt hast, ohne dich zunächst damit zu beschäftigen, dir wenigstens einiges an Grundlagenwissen anzueignen.

Der erste Fehler ist es schon mal, dass du für jeden Monat ein eigenes Blatt angelegt hast. Das erschwert Auswertungen, wie du sie vorhast. 
Wenn in einer Zelle Werte (Zahlen) und Texte (sonstige Zeichen) vermischt werden, ist das Ergebnis immer ein Text. Damit kann man nicht rechnen.

Hallo,

wo ich schon gerade am Meckern bin: in Spalte I würde diese Formel: =WENN(D3="";ZEITWERT("8:00");0) das gleiche bewirken, wie deine Formel. Zusätzlich hättest du den Vorteil, dass in Spalte D weitere Begriffe möglich sind, ohne die dann einzeln in deine Formel einarbeiten zu müssen.
Viele Grüße
Klaus-Dieter
Der Erfolg hat viele Väter, 
der Misserfolg ist ein Waisenkind
Richard Cobden
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste