Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Summe ausgewählter Spalten berechnen
#1
Hallo zusammen,

ich habe ein kleines Problem und wahrscheinlich einen Denkfehler.

Ich habe 10 Spalten in denen Zahlen stehen jeweils mit einer Überschrift.

Über VERGLEICH lasse ich mir dann anhand der gesuchten Überschriften 3 Spaltennummern ausgeben.
Die Ausgabe erfolgt in P8 /Q8 / R8.

Jetzt benötige ich eine Formel die mir anhand der ausgegeben Spaltennummer die dort enthaltenen Werte
zusammenrechnet. Also quasi Summewenns(Spalte(P8);Spalte(Q8);Spalte(R8))

Aber ich bekomme es nicht hin.

Habt ihr einen Tipp für mich?


Angehängte Dateien
.xlsx   MappeTest.xlsx (Größe: 9,69 KB / Downloads: 5)
Antwortento top
#2
Hallo,

bitte eine Beispielmappe (abgespeckt) hier einstellen!

Sigi
Antwortento top
#3
Sorry vergessen, ist drin.
Antwortento top
#4
Moin

Code:
=SUMME(SUMMEWENNS(A2:L2;A1:L1;P2:R2))
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#5
Hi,

klappt leider nicht. Wirft dann immer nur die Summe von Spalte 4 aus,
aber nicht die Summe von Spalte 4 + Spalte 8 + Spalte 11.
Antwortento top
#6
Hallo, vielleicht muss die Formel bei dir noch mit CSE abgeschlossen werden; bei mir klappt das (auch so) ...: 

Arbeitsblatt mit dem Namen 'Tabelle1'
NO
5Prüfsumme1454
6
7Formel:1454

ZelleFormel
O5=SUMME(D2;H2;K2)
O7=SUMME(SUMMEWENNS(A2:L2;A1:L1;P2:R2))
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Jörg

"Wer immer tut, was er schon kann, bleibt immer das, was er schon ist." - Henry Ford
Antwortento top
#7
Danke für den Hinweis, Jörg.
Alternativ ersetzt man SUMME durch SUMMENPRODUKT.
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste