Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Summe aus Wenn-Funktionen
#1
Hallo,
ich habe euch eine Beispieltabelle beigefügt. Ihr seht hier Mitarbeiter, die bestimmte Aufgaben haben.
Ich möchte nun eine Soll-Ist-Auswertung mit Formeln hinterlegen.
Im Soll möchte ich die Personen - welche Ausprägung die Qualifikation hat. Dafür würde ich =SUMMENPRODUKT((REST(ZEILE(W5:W22);2)=0)*(W5:W22<>"")) nehmen.

Nun fehlt noch das Ist. Hinter den vollen Kreisen liegt eine 3, hinter den halben eine 2, hinter den Viertelkreisen eine 1.

Wenn Soll > Ist, dann -1, ansonsten 1. Beispiel: Zeile M5&M6 - das wäre dann -1, und W13&W14 ist 1. Jetzt brauche ich eine Formel, die ich quasi über die gesamte Spalte ziehen kann, damit er mir die Summe aus den Soll-Ist Abgleichen der Mitarbeiter bildet.
Die ursprüngliche Datei umfasst 400 MA, ich möchte das also nicht unbedingt händisch summieren.


Angehängte Dateien
.xlsx   WennFunktion.xlsx (Größe: 24,26 KB / Downloads: 19)
Antwortento top
#2
Hallöchen,

eine Summe über eine ganze Spalte sollte doch recht einfach sein. =SUMME(A:A) bringt die Summe der Spalte A. Ich vermute aber, Du willst wissen, wie oft z-B. -1 vorkommt? Das könntest Du mit ZÄHLENWENN herausbekommen.
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#3
SUMMEWENN stetzt doch voraus, dass die Ergebnisse des Soll-Ist-Abgleichs eines jeden Mitarbeiters schon vorliegen. Ich suche aber einen Automatismus, der dies für alle Mitarbeiter macht, damit ich die jeweiligen WENN Funktionen nicht manuell eingeben muss.
Antwortento top
#4
Hallöchen,

Zitat:Wenn Soll > Ist, dann -1, ansonsten 1. Beispiel: Zeile M5&M6 - das wäre dann -1, und W13&W14 ist 1. Jetzt brauche ich eine Formel, die ich quasi über die gesamte Spalte ziehen kann, damit er mir die Summe aus den Soll-Ist Abgleichen der Mitarbeiter bildet.

sieht für mich erst mal so aus, als ob Du eine Spalte hast wo reichlich 1 oder -1 steht und Du vielleicht ermitteln willst, was überwiegt oder wie groß die Differenz zwischen der Anzahl + und - ist. Wenn dort jedoch nix steht wird es schwer eine Aussage zu treffen ...
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#5
Nein, eine solche Spalte gibt es nicht.
Antwortento top
#6
Hallöchen,

wo und aus was soll denn dann die Summe gebildet werden? Ich habe mir jetzt mal Deine Datei geladen. Da hast Du in Zeile 23 einfach nur gezählt, ob in jeder zweiten Zeile was drin steht. Die Zahl in Zeile 24 ist manuell eingetragen. -1 steht nirgends, nicht mal in der Legende, wobei die Zahlen dort nix mit einem Soll-Ist-vergleich zu tun haben.

Wenn Du aber "nur" wissen willst, wie oft ein Wert einer Spalte grösser als der folgende ist dann z.B. so, mal für die Spalte M

=SUMMENPRODUKT(($M$5:$M22>$M$6:$M23)*($M$6:$M23<>"")*1)
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#7
Moin zusammen,

wenn man im Tabellenblatt - "Silberthütte" in  Zeile C23:W24 klickt, erscheint ein Hinweistext!, wie funktioniert das?
Gruß Klaus

es Grüßt der niederRhein! 17

Office 2010
Antwortento top
#8
Hi Klaus,

das geht über Datenüberprüfung ==>Eingabemeldung
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#9
Wink 
Vielen lieben Dank Günther! 43
Gruß Klaus

es Grüßt der niederRhein! 17

Office 2010
Antwortento top
#10
schauan schrieb:Hallöchen,

wo und aus was soll denn dann die Summe gebildet werden? Ich habe mir jetzt mal Deine Datei geladen. Da hast Du in Zeile 23 einfach nur gezählt, ob in jeder zweiten Zeile was drin steht. Die Zahl in Zeile 24 ist manuell eingetragen. -1 steht nirgends, nicht mal in der Legende, wobei die Zahlen dort nix mit einem Soll-Ist-vergleich zu tun haben.

Wenn Du aber "nur" wissen willst, wie oft ein Wert einer Spalte grösser als der folgende ist dann z.B. so, mal für die Spalte M

=SUMMENPRODUKT(($M$5:$M22>$M$6:$M23)*($M$6:$M23<>"")*1)
Genau, ich will wissen, wie oft der Wert einer Spalte grösser als der folgende ist, dann soll er -1 für dieses Paar ausspucken, ansonsten 1. Und ich möchte dann die Summe aus allen Paaren. Aber nur, wenn die Zellen auch gefüllt sind.
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste