Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Statustext bei Zelleneintragungen aktualisieren
#1
Lightbulb 
Guten Morgen ins Forum,

Ich bin ziemlicher Excel Noob und kenne mich nur mit den Grundlagen aus. Daher ersuche ich eure Hilfe Smile
Ich möchte/muss eine Datei bauen, die Status Meldungen wiedergibt, wenn Eintragung in verschiede Spalten gemacht werden. 

Generell habe ich die Tabelle so aufgebaut, dass im Blatt 1 die Berechnungen und im Blatt 2 die Daten hinterlegt sind.
Tabelle befindet sich auch im Anhang.

Das Statusmeldefeld Spalte R ist erstmal leer.
Wenn Eintragung in Spalte B gemacht werden soll der Status 1 (aus Tabellenblatt2) in Spalte R gespiegelt werden.
sobald zusätzlich Eintragung in Spalte L gemacht werden soll der Status 3 in Spalte R gespiegelt werden.
sobald zusätzlich  Eintragung in Spalte K gemacht werden soll der Status 5 in Spalte R gespiegelt werden.
und so weiter.

Die erste Statusmeldung bekomme ich noch hin..
über ...
=WENN(B9="";"";Data!$E$2)

aber jetzt wird es für mich Problematisch, weil ich einfach zu wenig Excel Kenntnisse besitze um das miteinander zu verknüpfen.

Die Statusmeldung soll sich aktualisieren wenn in der passenden Spalte eine Eintragung gemacht wird.

Hoffe auf Hilfe 

Beste Grüße
.xlsx   HAE Daily Catch Up.xlsx (Größe: 1,32 MB / Downloads: 5)
Antworten Top
#2
Hola,
wie der jeweilige Status immer nacheinander eingegeben, also zuerst ein Eintrag in Spalte B, danach in L, danach in K...oder kann das auch immer willkürlich sein?
Gruß,
steve1da
Antworten Top
#3
Hi steve1da,

also vielleicht nochmal zur Erklärung.
Das ist im Prinzip eine Übersicht zu einem Fertigungsauftrag.

Auftragseingang wird in Spalte B über das Datum erfasst.
Sobald in Spalte B das Datum steht soll in Spalte R dann der Text stehen, der im Tabellenblatt 2 an erster Stelle steht.
Das Datum in Spalte B bleibt permanent stehen und es wird hier keine Änderung mehr vorgenommen.

Der Auftrag wird dann von Abteilung X weiterbearbeitet und Abteilung C pflegen dann den Zeitpunkt ihrer Bearbeitung in  Spalte L ein.
Daraufhin soll sich in Spalte R der vorherige Status ändern.

Spalte B              - Spalte R
25.10.2023          Auftrag angenommen

Spalte L                Spalte R
26.10.2023          Auftrag in Bearbeitung

usw.

VG
Antworten Top
#4
Dann prüf einfach rückwärts.
=wenn(S2<>"";Data!E9;wenn(R2<>"";Data!E8;wenn(M2<>"";Data!E7;........;""))))))))
Antworten Top
#5
Hi nochmal,

irgendwas mach ich falsch..
Das Ergebnis ist jetzt in der Spalte K immer 0 anstelle eines Textes  Huh

Die Daten aus der Tabelle habe ich nun so eingegeben, da du ja meintest die Abfrage von hinten zu starten:

=WENN(J10<>"";'Daily Dispatch'!F10;WENN('Daily Dispatch'!G10<>"";'Daily Dispatch'!F8;WENN('Daily Dispatch'!K10<>"";'Daily Dispatch'!F6;WENN('Daily Dispatch'!L10<>"";'Daily Dispatch'!E1:H5;WENN('Daily Dispatch'!B11<>"";'Daily Dispatch'!E1:H5;"")))))

VG und Danke schon mal
Antworten Top
#6
Wann und wo holst Du mit Deiner Formel denn Werte (oder Texte) aus Deiner Data-Tabelle? So kann auch nichts angezeigt bzw. eingetragen werden!
[Bild: attachment-190.gif]
Gruß Günter
aus der Helden-, Messe-, Musik-, Buch-, Universitäts- und Autostadt Leipzig
Antworten Top
#7
Hallo Glausius,

wie vorhin geschrieben. Ich bin ein Anfänger und weiß eigentlich gar nicht recht was ich da tue  Angel
Vielleicht habe ich auch nur umständlich beschrieben.

Ziel ist es in der Spalte R bei z.B. R8 immer einen neuen Status Text geschrieben zu bekommen. Der alte Status soll sich dann sozusagen überschreiben, wenn ich in der gleichen Spalte Einträge mache.
z.B.
Eintrag bei A8 = Status 1 in Zelle R8
Eintrag bei B8 = Status 2 in Zelle R8
Eintrag bei C8 = Status 3 in Zelle R8
usw.

Die Textinhalte für die Status Meldungen liegen im Tabellenblatt2 (Data)

Für mein beschränktes Wissen:

=WENN(J10<>"";'Daily Dispatch'!$F$10; 
Das funktioniert auch für den, ich nenne es mal, ersten Status.
aber wenn ich die Formel dann weiter schreibe um im in der gleichen Zelle den nächsten Status angezeigt zu bekommen steht da nur Wert
Beispiel:
=WENN(J9<>"";Data!$F$9);WENN(K9<>"";Data!$F$6)
weiter habe ich das dann gar nicht getrieben, weil es ja nicht funktioniert hat.

Ich habe die Datei im ersten Post in den Anhang gestellt.
Evtl. hast du oder ein Gütiger anderer Experte Zeit und Lust  mal einen Überblick zu verschaffen Smile

VG
Antworten Top
#8
Ich dachte du willst die Werte aus dem Blatt DATA holen, aktuell holst du sie aus dem Blatt Daily Dispatch.
Das ist ja dann genau anders herum als im ersten Post.
[-] Folgende(r) 1 Nutzer sagt Danke an steve1da für diesen Beitrag:
  • Tschiboo82
Antworten Top
#9
Ja du hast recht aber ich weiss nicht warum Excel das so einträgt.
Ich wechsle zwischen den Tabellenblättern und der Bezug ist ein anderer.  05
Antworten Top
#10
Dann fängst du im flachen Blatt an die Formel zu tippen.
Man kann dir aber auch leider keine komplette Formel liefern weil du nur den Anfang beschrieben hast und dann "und so weiter" kam. Da musst du dann selber probieren.
[-] Folgende(r) 1 Nutzer sagt Danke an steve1da für diesen Beitrag:
  • Tschiboo82
Antworten Top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste