Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Spalten in Zeilen Spezial
#1
Hallo, ich bin neu hier im Forum und habe gleich eine sehr spezielles Problem. Ich suche eine Möglichkeit eine Tabelle zu transponieren in Form von

Überschrift1 Überschrift2 Überschrift3 ..
Text1           Zahl1          Datum1 ..
Text2           Zahl2          Datum2 ..
.
.
nach
Überschrift1: Text1
Überschiftt2: Zahl1
Überschrift3: Datum1
.
.
Trennzeichen
Überschrift1: Text2
Überschrift2: Zahl2
Überschrift3: Datum2
.
.
Trennzeichen
usw.

ich hoffe es ist in der kurzen Form verständlich rübergekommen wie die Tabelle vorher nachher aussehen soll.

Vielen Dank und Liebe Grüße

Michael
Antwortento top
#2
Hi,

ich glaube, Du suchst nach der  MTRANS Funktion ;)

lg
Cyb
Antwortento top
#3
Ist das nicht wie beim transponieren, nur das ich beim transponieren die Werte eintrage und bei MTRANS bleiben die origniale Zellen vorhanden und wenn dort eine Änderung eingetragen wird, wandert diese ebenfalls in die MTRANS Zelle?

Ich habe knapp zwanzig Spalten und fasst 2000 Zeilen die in eine (oder 2 Spalten müssen)
Immer mit der Spaltenüberschrift vorne und dem Zellwert dahinter.
Soll also 40.000 Zeilen geben in Form von:
Überschrift: Zellwert

Die Überschrift muss sich also immer aus der ersten Zeile geholt werden und die Werte nach jeder Zeile eine Zeile tiefer.

Da komme ich mit Transponieren und Mtrans nicht hin.

Grüße
Michael
Antwortento top
#4
Moin!

Zitat:ich hoffe es ist in der kurzen Form verständlich rübergekommen wie die Tabelle vorher nachher aussehen soll


Eine Datei mit dem korrekten Aufbau wäre besser gewesen.
Daher wirst Du meine beiden Formeln anpassen müssen.
Als Trennzeichen habe ich … gewählt.

ABCDEF
1Überschrift1Überschrift2Überschrift3Überschrift1Text1          
2Text1          Zahl1         Datum1Überschrift2Zahl1         
3Text2          Zahl2         Datum2Überschrift3Datum1
4Text3Zahl3Datum3
5Text4Zahl4Datum4Überschrift1Text2          
6Überschrift2Zahl2         
7Überschrift3Datum2
8
9Überschrift1Text3
10Überschrift2Zahl3
11Überschrift3Datum3
12
13Überschrift1Text4
14Überschrift2Zahl4
15Überschrift3Datum4
16

ZelleFormel
E1=WENN(REST(ZEILE();4)=0;"…";INDEX(A$1:C$1;;REST(ZEILE();4)))
F1=WENN(REST(ZEILE();4)=0;"…";INDEX($A:$C;GANZZAHL(ZEILE()/4)+2;REST(ZEILE();4)))

Formeln aus E1:F1 nach unten ziehen.
Wenn Du z.B. 7 Überschriften hast, musst Du die 4 in 8 ändern.

Gruß Ralf
Gib einem Mann einen Fisch und du ernährst ihn für einen Tag. 
Lehre einen Mann zu fischen und du ernährst ihn für sein Leben. (Konfuzius)
Antwortento top
#5
Noch eine Ergänzung:
Da INDEX() intern ohnehin nur Ganzzahlen berechnet, geht statt:
INDEX($A:$C;GANZZAHL(ZEILE()/4)+2;REST(ZEILE();4))
auch kürzer:
INDEX(A:C;ZEILE()/4+2;REST(ZEILE();4))
(die Spalten brauchen hier auch nicht fixiert werden, da nur nach unten gezogen wird)
Gib einem Mann einen Fisch und du ernährst ihn für einen Tag. 
Lehre einen Mann zu fischen und du ernährst ihn für sein Leben. (Konfuzius)
Antwortento top
#6
Thumbs Up 
Ja Klasse, das sieht schon sehr gut aus.
Vielen Dank
100
Antwortento top
#7
Hallo Leute, Ich habe ein ähnliches Problem nur kann ich es nicht mit den Info hier umsetzen:

Ich habe mal einen Abschnitt der Tabelle hier rein:
[ Bild bitte als Datei hochladen! ]
Das Ergebnis soll so aussehen:
[ Bild bitte als Datei hochladen! ]
Also im Endeffekt möchte Ich wissen wo die Strömung am zweiten Sensor auftaucht. Dabei sollte der Wert der Messung nicht kaputt gehen.
Hat hier jemand eine Idee dazu?
Danke und Grüße


Angehängte Dateien
.xlsx   Hilfe Datei.xlsx (Größe: 13,35 KB / Downloads: 3)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste