Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Spalte nach Anzahl bestimmter Inhalte filtern
#1
Hallo liebes Excel Forum,

ich habe ein Problem und schaffe es leider nicht mir selber eine Lösung einfallen zu lassen... 

Ich habe eine Spalte mit vielen Zeilen, in denen die  Werten alle 17 Zeichen lang sind. Buchstaben und Zahlen. Die meisten Werte kommen in der Spalte doppelt vor, einige allerdings 3 mal oder öfter vor. Diese Zeilen möchte ich mir angezeigen lassen. 

Also beispielhaft: 

alt          neu
A          A
A          A
B          C
B          C
C          C
D          A
C
C
A

Ihr würdet mir wahnsinnig weiterhelfen, wenn es dafür eine Lösung gäbe.

Vielen lieben Dank schon mal!

Grüße
olooz
Antwortento top
#2
Hallo, so wie ich das verstanden habe kann man das mit Power Query lösen. Allerdings bekomme ich eine sortierte Spalte. Nicht wie deine Vorgabe...
Gruß Jörg

"Wer immer tut, was er schon kann, bleibt immer das, was er schon ist." - Henry Ford
Antwortento top
#3
Hi,

Lösung mit (ausblendbarer) Hilfsspalte:

Arbeitsblatt mit dem Namen 'Tabelle1'
ABC
1WerteHSErg.
2a2a
3a3a
4bc
5bc
6c6c
7da
8c8
9c9
10a10

ZelleFormel
B2=WENN(ZÄHLENWENN($A$2:$A$15;A2)>2;ZEILE();"")
C2=WENNFEHLER(INDEX(A:A;KKLEINSTE($B$2:$B$15;ZEILE(A1)));"")
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.2) erstellt. ©Gerd alias Bamberg
Gruß Günter
Jeder Fehler erscheint unglaublich dumm,
wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#4
Das ging ja super schnell. Vielen Dank!

Allerdings habe ich mich nicht korrekt augedrückt. Die Zeilen dürfen sich nicht verändern.

heißt:

Spalte  alt          neu
1          A          A
2          A          A
3          B          blank
4          B          blank
5          C          C
6          D          blank
7          C          C
8          C          C
9          A          A

So sollte es aussehen. Dann kann ich die neue Spalte filtern und bestimmt ganze Zeilen löschen.

Wie muss ich die Formel dann modifizieren? 

Liebe Grüße
olooz
Antwortento top
#5
Hi,

dann so:

Arbeitsblatt mit dem Namen 'Tabelle1'
ABC
1WerteHSErg.
2a2a
3a3a
4b
5b
6c6c
7d
8c8c
9c9c
10a10a

ZelleFormel
B2=WENN(ZÄHLENWENN($A$2:$A$15;A2)>2;ZEILE();"")
C2=WENNFEHLER(INDEX(A:A;B2);"")
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.2) erstellt. ©Gerd alias Bamberg
Gruß Günter
Jeder Fehler erscheint unglaublich dumm,
wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#6
...

und so sparst du dir noch die Hilfsspalte.

Arbeitsblatt mit dem Namen 'Tabelle1'
AB
1WerteErg.
2aa
3aa
4b
5b
6cc
7d
8cc
9cc
10aa

ZelleFormel
B2=WENNFEHLER(INDEX(A:A;WENN(ZÄHLENWENN($A$2:$A$15;A2)>2;ZEILE();""));"")
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.2) erstellt. ©Gerd alias Bamberg
Gruß Günter
Jeder Fehler erscheint unglaublich dumm,
wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#7
Hallo, oder einfach(er)..:

PHP-Code:
=WENN(ZÄHLENWENN($A$2:$A$15;A2)>2;A2;""
Gruß Jörg

"Wer immer tut, was er schon kann, bleibt immer das, was er schon ist." - Henry Ford
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste