Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Schnittpunkte von Aussendurchmesser Zylinder zu Querbohrung im 3D Bereich berechnen
#1
Hallo liebe Excelfreunde, 
Gibt es mit Excel eine Möglichkeit die Schnittpunkte einer Bohrung zum Aussendurchmesser des Zylinders oder der Welle zu berechnen?
Ich bräuchte 60 Punkte an der Kante von Bohrung D=10mm zur Welle D=30mm. Falls es die Darstellung erleichtern würde, könnte ich auch ein Bild des Werkstückes einstellen.
Ich bedanke mich schon ganz herzlich für Eure Tipps oder Lösungen!!!
Vielen Dank und allen viel Gesundheit!!
Gruss
Uwe

PS: Habe Excel 2016
Antwortento top
#2
Ohne Beispieldatei und genauere Erläuterungen wird das nichts ;)

Nur so als Tipp.

BG ruppy
Antwortento top
#3
Zum Bessern Verständnis habe ich ein Bild eingefügt, ich wollte zur Programmierung einer CNC Drehmaschine diese einzelnen schwarzen Punkte, so ca. 40, mit Excel errechnen. Kann man mit Excel diese Aufgabe lösen?
Mittelpunkt der Querbohrung, Durchmesser 10, in der Z-Achse wäre -25mm und der Abstand von Mitte des Zylinders bis zum Aussendurchmesser X-Achse 15mm, diese Werte möchte ich bei anderen Werkstücken einfach ändern können und dann die eingezeichneten Punkte errechnen lassen.
Wenn dies machbar ist, wäre es eine riesen Erleichterung bei der Programmierung der Maschine.
LG
Uwe

   



Tabelle1

ABCD
1
2XZAnzahl PunkteBohrungsØ
315-254010

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Antwortento top
#4
Hallöchen,

erst mal grundsätzlich ja, je nachdem, was noch für Bedingungen kommen. Willst Du die Lage der Punkte auf dem Zylinder in allen 3 Achsen? Neben x und z wäre ja auch noch die Höhe y relevant. Zur Vereinfachung der Berechnung sollte die Bohrung dazu senkrecht oder waagerecht stehen.

Als Ansatz würde ich hierfür 2 Kreissegmente nehmen, eins zur kleinen Bohrung und eins zum Zylinder.
Weiterhin Kreissektor und Pythagoras.
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#5
Hallo Andre,
vielen Dank für deine Rückantwort!!!!

Ja, ich brauche auch noch die dritte Achse "Y" um die Kante der Bohrung mit dem Fräser genau abfahren zu können.

Die Querbohrung ist immer Senkrecht zum Zylinder am Aussendurchmesser.

Leider sind meine mathematischen Kenntnisse nicht ausreichend um in Excel eine solche Formel zu erstellen Huh

Wäre es von deiner Seite aus möglich mich hierbei mit einer Formel zu unterstützen????

Würde mich riesig freuen wenn da was möglich wäre.

Viele Grüße aus dem Coburger Land und immer Gesund bleiben wünscht

Uwe
Antwortento top
#6
Moin Uwe!
Gehört zu einer CNC-Maschine nicht automatisch ein CAD-Programm mit Schnittstelle zur Maschine?

Fragt sich Ralf
Gib einem Mann einen Fisch und du ernährst ihn für einen Tag. 
Lehre einen Mann zu fischen und du ernährst ihn für sein Leben. (Konfuzius)
Antwortento top
#7
Hallo Ralf,
in unserem Betrieb bleiben die Dreher leider auf der Strecke. CAM System ist nur auf Haidenheim Steuerung für Fräsen ausgelegt, beim Drehen wird ausser teure Maschinen mit Grundausstattung, bei Zyklen nichts investiert. Deshalb such ich eine Möglichkeit in Excel mir gewisse Programmierhilfen zu erstellen, wie z. B. das Entgraten von Bohrungen auf der Mantelfläche.
Habe selbst ein CAD Programm, aber wenn ich 40 Punkte oder mehr darin abfragen muss ist schon sehr aufwending. So hätte ich gerne in Excel diese Punkte errechnen lassen und dann die Koordinaten kopiert und über den Editor der Maschine ins Programm eingefügt.
LG
Uwe
Antwortento top
#8
Hallo Uwe,

das ist doch keine Frage von Excel.

Eine Bohrung ist doch auch ein Zylinder. Bei Tante Goo.. gibt es Anleitungen zur Berechnung der Schnitte zweier Zylinder.
helmut

Für mich ist die Möglichkeit in Excel an Zellen und Bereichen Namen zu vergeben die wichtigste Funktionalität.
Sie macht Formeln und den VBA-code verständlicher. Für Makros gilt die Regel: "Nur über benannte Bereiche auf den Inhalt der Zellen zugreifen."
Und wofür sind Regeln da? Um nachzudenken bevor man sie bricht.





Antwortento top
#9
Hallöchen,

hier mal der Ansatz. Ich hab die 40 Punkte jetzt anhand der 9 (360 Grad / 40) fix in der Formel, das könnte man variabel gestalten. Ebenso hab ich den Mittelpunkt der Bohrung zu Null gesetzt, auch hier könntest Du die tatsächliche Lage bei Z verrechnen.Die Formel einfach so weit wie nötig nach unten ziehen.

Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDEF
1dmr_zyldmr_boPunktXYZ
225101012,55
320,7812,47564034,94
431,5512,40352774,76
542,2712,2921564,46
652,9412,14933744,05
763,5411,98826093,54
874,0511,82571352,94
984,4611,677262,27
1094,7611,55821791,55
11104,9411,48243880,78
1211511,45643920
13124,9411,4824388-0,78
14134,7611,5582179-1,55
15144,4611,67726-2,27
16154,0511,8257135-2,94
17163,5411,9882609-3,54
18172,9412,1493374-4,05
19182,2712,292156-4,46
20191,5512,4035277-4,76
21200,7812,4756403-4,94
2221012,5-5

ZelleFormel
D2=RUNDEN((SIN((PI()/180*9)*(C2-1))*$B$2/2);2)
E2=WURZEL(($A$2/2)^2-D2^2)
F2=RUNDEN((COS((PI()/180*9)*(C2-1))*$B$2/2);2)
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.2) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#10
Hallo Andre,
vielen vielen Dank für deine Bemühungen!!!
Ich werde es heute wahrscheinlich noch nicht schaffen es auszuprobieren, sieht aber sehr viel versprechend aus!

Viele Grüße
Uwe
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste