Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

SVerweis mit 2 Variablen
#1
Hi zusammen,

ich habe die wundervolle Aufgabe erhalten aus 2 Tabellen, die jeweiligen Produktbuchungen für Monate in einer neuen Tabelle zusammenzuführen.

Die Tabelle schaut folgendermaßen aus:

a = Kunde
b = produkt
c= Anzahl Buchungen des Produktes für den Jeweiligen Kunden im Monat x. Also 
 A               B              Monat 1    Monat 2   Monat 3
1 Produkt 1  Kunde 1     2              2               4
2 Produkt 2  Kunde 1     6              4               5
3 Produkt 2  Kunde 2     9              22              3 
4 Produkt 3  Kunde 1     12             11             3
5 Produkt 4  Kunde 1     3               3               4

Produkte und Kunden können also mehrfach ind er Matrix vorkommen, die Kombination aus Produkt x Und Kunde y jeweils nur einmal in Spalte A und B.


Jetzt habe ich eine neue Tabelle, in der die Monate leer sind. Ich will nun in der neuen Tabelle eine Funktion im Feld "1:Monat1:1 einfügen, der die gesamte Matrix nach der Kunden / Produkt Kombi in der alten tabelle durchsucht und mir den Treffer für den Umsatz mit der Kombination in dem Monat ausweist.

Kann mir da jemand weiterhelfen?

Danke und Gruß
Antworten Top
#2
Hi,

dann zeig mal eine Mustertabelle mit Wunschergebnissen.
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antworten Top
#3
Hola,
das geht zB mit Summenprodukt().
Gruß,
steve1da
Antworten Top
#4
Hi zusammen,

ich habe euch mal eine xls. als Beispiel angehängt. Aus der linken Tabelle will ich die Bestellungen der Kombination Kunde & Produkt in dem gelb markierten Bereich in der rechten Tabelle eintragen.

Irgendwie Verzweifle ich an der SVERWEIS Formel mit WAHL Funktion darin. Es wäre zu beachten, dass die Kombination Kunde und Produkt in der rechten Tabelle wild durcheinandergewürfelt sein kann.

Danke euch und Gruß!


Angehängte Dateien
.xlsx   Beispiel1.xlsx (Größe: 30,35 KB / Downloads: 7)
Antworten Top
#5
Warum da jetzt keine Monate zu sehen sind weiß ich nicht.
Code:
=XVERWEIS(E2&F2;$A$2:$A$7&$B$2:$B$7;$C$2:$C$7)
[-] Folgende(r) 1 Nutzer sagt Danke an steve1da für diesen Beitrag:
  • maxffmmax
Antworten Top
#6
Hallo,

ich habe deine Anfrage so verstanden

 
Gruß Stephan


Angehängte Dateien
.xlsx   Beispiel1.xlsx (Größe: 11,17 KB / Downloads: 4)
Antworten Top
#7
Hat geklappt, 1000 Dank!
Antworten Top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste