Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

SVerweis Name wird nicht/falsch übertragen
#1
Hallo, wir haben eine Lieferliste aufgebaut, in die wir eingehende Bestellungen eintippen.
Beim Eintippen der Bestellungen (Registerblatt #1-4 bis #17-20) geben wir nur die Artikelnummern und die Mengen ein.

Im Registerblatt Berechnungen werden dann mit einem SVerweis die Namen der Cocktails ausgegeben.

Die Cocktails sind aufgelistet im Registerblatt Cocktails.
Dies ist der Code vom SVerweis, mit dem der Name ausgegeben wird:
Code:
=WENN('#1-4'!D20>0;(SVERWEIS('#1-4'!D20;Cocktails!$B$6:$E$100;2));" ")

Der Code funktioniert auch bei fast allen Namen aus der Liste im Registerblatt Cocktails, nur bei den Cocktails mit den
Artikelnummern 301-303 und 201&202 nicht.
Bei diesen Cocktails werden im Registerblatt Berechnungen Zahlen angezeigt anstatt des Namens.

Und ich komme einfach nicht dahinter, woran es liegt.
Die Cocktails sind in der Auflistung alle gleich formatiert (Standart) und der Code vom SVerweis ist überall gleich.

Deswegen hänge ich die Datei an diesen Beitrag an und hoffe, dass ihr vielleicht den Fehler findet, den ich einfach nicht sehe und seit Stunden suche.
Ich habe in die Bestellung 1 die Artikelnummern eingefügt, bei denen es die Probleme gibt.

Ich würde mich über eure Hilfe freuen.
Danke und VG TxM


Angehängte Dateien
.xlsx   Lieferliste für Forum.xlsx (Größe: 86,57 KB / Downloads: 4)
Antwortento top
#2
Hola,

da du beim Sverweis den 4. Parameter weggelassen hast, nimmt Excel automatisch WAHR. Das bedeutet dass deine Suchmatrix aufsteigend sortiert sein muss - ist sie aber nicht. Daher musst du bei deinen Sverweisen den 4. Parameter auf FALSCH oder 0 stellen.

Gruß,
steve1da
[-] Folgende(r) 1 Benutzer sagt Danke an steve1da für diesen Beitrag:
  • TxM
Antwortento top
#3
Wow, jetzt bin ich etwas perplex, dass du das so schnell gefunden hast. 

Vielen Dank für den Hinweis! 28
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste