Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

SVERWEISE kombinieren
#1
Tagchen,

ich habe in den Spalten D bis P jeweils eine Formel, die über einen SVERWEIS bestimmte Bedingungen abfragt und die Werte, die in Spalte B stehen um einen bestimmten Zeitraum verschieben (z. B. wenn anstatt um 8:00 Uhr um 9:00 Uhr gefrühstückt wurde, werden die Werte in Spalte B um 60 Zeilen nach vorne verschoben und entsprechend in Spalte R angezeigt). Das funktioniert auch alles wunderbar. Ich frage mich nur, ob es möglich ist, die SVERWEISE, die momentan auf 13 Spalten verteilt sind und 13 verschiedene Bedingungen (Zeiten) abfragen, nicht auch in einem einzigen SVERWEIS abgefragt werden können?

Ist sowas möglich und wenn ja, wie sollte das aussehen?

Hier zwei Beispiele für die Formeln (ansonsten sind die auch in der Datei im Anhang zu finden):

=WENN(ISTFEHLER(SVERWEIS(A3+0.5/1440;$A$126:$H$126;1;1));B3;WENN(ODER(UND(A3>=SVERWEIS(A3+0.5/1440;$A$126:$H$126;3;1);A3<=SVERWEIS(A3+0.5/1440;$A$126:$H$126;6;1));UND(A3<=SVERWEIS(A3+0.5/1440;$A$126:$H$126;4;1);A3>=SVERWEIS(A3+0.5/1440;$A$126:$H$126;7;1)));"-";WENN(A3>SVERWEIS(A3+0.5/1440;$A$126:$H$126;2;1)+WENN(SVERWEIS(A3+0.5/1440;$A$126:$H$126;5;1)>0;0.5/1440;-0.5/1440);B3;BEREICH.VERSCHIEBEN(B3;-1*SVERWEIS(A3+0.5/1440;$A$126:$H$126;5;1);0))))

=WENN(ISTFEHLER(SVERWEIS(A3+0.5/1440;$A$127:$H$127;1;1));B3;WENN(ODER(UND(A3>=SVERWEIS(A3+0.5/1440;$A$127:$H$127;3;1);A3<=SVERWEIS(A3+0.5/1440;$A$127:$H$127;6;1));UND(A3<=SVERWEIS(A3+0.5/1440;$A$127:$H$127;4;1);A3>=SVERWEIS(A3+0.5/1440;$A$127:$H$127;7;1)));"-";WENN(A3>SVERWEIS(A3+0.5/1440;$A$127:$H$127;2;1)+WENN(SVERWEIS(A3+0.5/1440;$A$127:$H$127;5;1)>0;0.5/1440;-0.5/1440);B3;BEREICH.VERSCHIEBEN(B3;-1*SVERWEIS(A3+0.5/1440;$A$127:$H$127;5;1);0))))

Danke euch!


Angehängte Dateien
.xlsx   Test.xlsx (Größe: 38,42 KB / Downloads: 9)
Antwortento top
#2
Hi,

es ist völlig unklar, was das werden soll. Und Dir ist wohl nicht klar, was A3+0,5/1440 ergibt!
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#3
Vermutlich zur Vermeidung unerwünschter Folgen der Gleitkommaproblematik. Man hätte auch 1%% verwenden können.
Antwortento top
#4
Hi,

vielleicht sieht man es besser am Bild:

   

Abgesehen davon, dass dieser Term:

SVERWEIS(A3+0,5/1440;$A$126:$H$126;1;1)

in dieser Liste fast nie einen Fehler erzeugt, wäre eine Abfrage mit VERGLEICH oder auch ZÄHLENWENN (je nach Intention des Abfragenden) einfacher.

Zeile 126 enthält einen Wert, der um 52/1440 höher ist als A3!
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste