Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

SVERWEIS soll nicht nur erste Spalte durchsuchen
#1
Hallo zusammen,

Ich habe zwei Tabellen, in der ersten Tabelle "Übersicht" finde ich eine Übersicht der Geräte mit Infos wie die Version, das Jahr usw.
In der zweiten Tabelle finde ich Auskunft darüber, ob das jeweilige Gerät Garantie hat.

Nun möchte ich in der Tabelle "Übersicht" mir mithilfe einer Formel anzeigen lassen, ob das jeweilige Gerät Garantie hat.
Dazu verwende ich die Verkettung von der Version mit dem Gerät, um diese mithilfe eines SVerweis in der Tabelle "Garantie" zu suchen.
Falls die Verkettung nicht gefunden wird, soll ein "NEIN" erscheinen, falls sie gefunden wird, soll das drin stehen, was in der "Garantie" Tabelle in dem jeweiligen Feld steht. 

Hierzu verwende ich folgende Formel für Feld E2 in der Tabelle "Übersicht":
=WENN(ISTFEHLER(SVERWEIS(F2;Garantie!A1:E4;4;FALSCH));"NEIN"; SVERWEIS(F2;Garantie!A1:E4; 5; FALSCH))

Folgendes Problem nun: 
In der Tabelle "Übersicht" fehlt bei der Version manchmal die vierte Ziffer, deswegen habe ich in der Tabelle "Garantie" eine Spalte mit einer verkürzten Verkettung erstellt. 
Nun ist es ja aber so, dass der SVerweis nur die erste Spalte absucht. 

Zum Beispiel müsste es in Tabelle "Übersicht" E2 "JA" heißen, da es die Kombination in Feld F2 in Tabelle "Garantie" gibt, allerdings nicht in der ersten Spalte. 

Gibt es eine Möglichkeit, dass der SVerweis die erste und die zweile Spalte absucht nach dem Suchkriterium, und dann, falls nicht vorhanden "NEIN" als Erebnis hat, fall aber vorhanden aus der jeweiligen Zeile das entsprechende Feld als Ergebnis?


.xlsx   Testdatei_Excelforum.xlsx (Größe: 19,67 KB / Downloads: 3)

Vielen Dank im Voraus und liebe Grüße!
Antwortento top
#2
Hola,


Code:
=WENNFEHLER(WENNFEHLER(SVERWEIS(F2;Garantie!$A$2:$E$4;5;0);SVERWEIS(F2;Garantie!$B$2:$E$4;4;0));"")

Gruß,
steve1da
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste