Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

SVERWEIS mit zwei Ergebnissen
#1
Hallo miteinander!

Ich habe folgendes Problem:

Ich habe eine Tabelle mit weit über 500 Zeilen, bei der in einer Spalte Namen stehen (alphabetisch sortiert). Einige wenige dieser Namen wiederholen sich.
Rechts neben dem Namen steht nun jeweils eine Zahl, die ich via SVERWEIS in einem anderen Tabellenblatt sichtbar machen möchte. Soweit kein Problem..
Bei den sich wiederholenden Namen ergibt sich aber das Problem, dass jeweils einmal eine Zahl und einmal eine Null neben dem Namen steht und der SVERWEIS automatisch immer die Null übernimmt, obwohl die andere Zahl benötigt wird. Dabei spielt es keine Rolle, ob die Null in der ersten oder zweiten Wiederholung des Namens steht.

Kann man das irgendwie umgehen?

LG, Yowo
Antwortento top
#2
Hi,

so?
Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDEF
1NamenWerteGesuchtName22
2Name117
3Name229
4Name13
5Name44
6Name55
7Name16
8Name27
9Name88
10Name29

ZelleFormel
F1=WENNFEHLER(INDEX(B:B;AGGREGAT(15;6;ZEILE($B$1:$B$10)/($A$1:$A$10=$E$1);ZEILE(A1)));"")
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#3
Danke Heart 

Das erspart mir zwei Hilfsspalten 17
Antwortento top
#4
Hi,
wenn du Google tabellen benutzt, kannst du doch auch die Filter-Funktion verwenden.

Auf das Beispiel von Willwissen bezogen:

=filter(B2:B10;A2:A10=E1)
Cadmus
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste