Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

SVERWEIS mit ARRAY kombinieren
#1
Hallo,

leider habe ich weder über Google-Suche (vielleicht fehlen mir die richtigen Begriffe) noch mit selber Probieren eine Lösung gefunden.

Ich möchte zwei Arrays (Zeilen) aus Zahlen in der Art wie SUMMENPRODUKT verarbeiten, allerdings ist eine der Zeilen variabel.
Mit SVERWEIS kriege ich eine Zelle, abhängig von der Zeile, aber ich benötige einen ARRAY abhängig von der Zeile.

Ich habe dazu eine Beispiel-Datei angehangen.
Ich möchte also z.B. alle Zahlen aus C1 - G1 mit den Zahlen aus Zeile 2 oder 3 wie in Summenprodukt verarbeiten, aber in einer Bedingung ähnlich SVERWEIS festlegen, ob es die zweite (Zweiter) oder dritte Zeile (Dritter) ist.

Ich hoffe, jemand kann mir helfen. 
HoboGobo
Antwortento top
#2
Hi,


Zitat:Ich habe dazu eine Beispiel-Datei angehangen.

wenn du rechts den Button "Attachment hinzufügen" angeklickt hättest, könnten wir sie auch sehen. Wink
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#3
Halöchen,

hier mal mit SUMME ein Ansatz, wie DU einen Zeilenbereich festlegen kannst.

Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDE
1NameWert1Wert2Wert3Wert4
2Ich1234
3Du5678
4Er9012
5
6Summe
7NameIch10

ZelleFormel
C7=SUMME(INDEX(B2:B4;VERGLEICH(B7;A2:A4;0);1):INDEX(E2:E4;VERGLEICH(B7;A2:A4;0);1))
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.2) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#4
Hallo André, reicht hier nicht ..:

PHP-Code:
=SUMME(INDEX(B2:E4;VERGLEICH(B7;A2:A4;0);)) 

Hier mal mehrere "Ansätze"..:

Arbeitsblatt mit dem Namen 'Blatt1'
ABCDE
1NameWert1Wert2Wert3Wert4
2Ich1234
3Du5678
4Er9012
5
6Summe
7NameEr12
812
912
1012
1112

ZelleFormel
C7=SUMME(INDEX(B2:B4;VERGLEICH(B7;A2:A4;0);1):INDEX(E2:E4;VERGLEICH(B7;A2:A4;0);1))
C8=SUMME(INDEX(B2:E4;VERGLEICH(B7;A2:A4;0);))
C9=SUMME(BEREICH.VERSCHIEBEN(B1:E1;VERGLEICH(B7;A2:A4;0);;;))
C10=SUMME(WAHL(VERGLEICH(B7;A2:A4;0);B2:E2;B3:E3;B4:E4))
C11=SUMME(INDEX((B2:E2;B3:E3;B4:E4);;;VERGLEICH(B7;A2:A4;0)))
Verwendete Systemkomponenten: [Windows (32-bit) NT 6.02] MS Excel 2010
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Jörg

"Wer immer tut, was er schon kann, bleibt immer das, was er schon ist." - Henry Ford
Antwortento top
#5
Hi Jörg,

ja, klar. Ich war in Gedanken nur schon beim nächsten Step, die Summe auch hinsichtlich der Spalten einzugrenzen, z.B. Summe von Ich im Bereich Wert2 : Werrt3, wobei die Begrenzung Wert2 und Wert3 dann auch per Auswahl oder Eingabe definiert werden.
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#6
Hallo,

entschuldigt bitte die späte Rückmeldung.
Ich konnte alles lösen und bin sehr dankbar für eure Hilfe.
Dass die Datei nicht angehangen wurde, ist wohl meiner Unerfahrenheit hier im Forum geschuldet.
Das ihr mir trotzdem helfen konntet/geholfen habt, spricht sehr für das Forum.

17 18
[-] Folgende(r) 2 Benutzer sagt Danke an HoboGobo für diesen Beitrag:
  • Jockel, schauan
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste