Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

SUMMEWENNS Kriterien
#1
Hallo zusammen,

ich sitze schon den ganzen Tag an einem Problem und komme einfach nicht weiter. Ich will 15min Werte (0.25h) zu einer Laufzeit aufaddieren, die von mehreren Spalten abhängig ist. 
Ich habe zwei Spalten (Spalten DM und DN) mit Einsen und Nullen die jeweils aussagen ob an der Stelle Messwerte vorhanden sind und die Messung lief. Beide sollten auf Eins stehen.

Jetzt der knifflige Teil. Ich will das die Zeitwerte solange aufaddiert werden wie jeweils ein Intervall läuft (Spalte BW) und gleichzeitig beide andere Spalten auf Eins stehen. Ein Intervall läuft solange wie in BW die gleiche Zahl steht (erst ganz viele Einsen, dann im nächsten Intervall ganz viele Zweien usw.)

Ich will also die 0.25h Werte aus Spalte DL solange aufaddieren wie in Spalte BW die gleiche Zahl steht und gleichzeitig die Eins in Spalte DM und DN. 

Bilder dazu im Anhang.

Alles Versuche das ganze mit WENN und SUMMEWENN, SUMMEWENNS oder SUMMEPRODUKT zu lösen haben leider nicht funktioniert. 
Ich hoffe jemand von euch kann mir weiterhelfen!

Danke und viele Grüße

baumeister



Dateiupload bitte im Forum - wie's geht: http://www.clever-excel-forum.de/thread-326.html .


Angehängte Dateien Thumbnail(s)
       
Antwortento top
#2
Am besten hat es bisher damit geklappt. Kann beim Fragezeichen eine bestimmte Zahl (zB "1") einsetzen und er bestimmt mir die Anzahl des ersten Intervalls. Brauche jetzt nur noch ein Kriterium, sodass er automatisch alle Intervalle von 1-x durchzählt. Muss das ganze für drei Filter mit zT. fast 600 Intervallen machen also manuell ist das eher nicht zu lösen. 

=ZÄHLENWENNS(DM12:DM60431;"1";DN12:DN60431;"1";BW12:BW60431;"?")
Antwortento top
#3
Moin

Versuche es mal mit Pivot.
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#4
Hallo baumeister,

Zitat:...sodass er automatisch alle Intervalle von 1-x durchzählt

ersetze das ? durch ZEILE(A1)

=SUMMEWENNS($DL$12:$DL$60431;$DM$12:$DM$60431;1;$DN$12:$DN$60431;1;$BW$12:$BW$60431;ZEILE(A1))

Beim kopieren der Formel nach unten wird dann daraus 1, 2, 3, …, n

Gruß
Fred
Antwortento top
#5
Hallo Fred 

Irgendwas funktioniert da leider noch nicht. 

Mit der Formel 

=SUMMEWENNS($DL$12:$DL$60431;$DM$12:$DM$60431;1;$DN$12:$DN$60431;1;$BW$12:$BW$60431;ZEILE(BW12)) 

bekomme ich 116 Ergebnisse, es sind aber 163 Intervalle. Zudem müssten die ersten 3 Intervalle =0 sein weil dort durchweg keine Messdaten vorhanden waren, die Spalte DM also auf 0 stand. Bei der Formel kriege ich für das erste Intervall bereits eine Zahl ungleich 0 raus. 

Bin jetzt soweit das man die Spalte DL nicht mehr braucht indem ich ZÄHLENWENNS einfach mit 0,25 multipliziere.

=ZÄHLENWENNS($DM$12:$DM$60431;"1";$DN$12:$DN$60431;"1";$BW$12:$BW$60431;"8")*0,25

Die Frage bleibt also weiterhin was ich für die "8" im Bsp. einsetzten kann sodass excel die Intervalle nach und nach durchzählt. Wichtig ist das für jedes Intervall ein eigener Wert ausgegeben wird und auch Intervalle ohne Laufzeit als Ergebnis den Wert 0 erhalten. 


Danke für den Hinweis shift-del, ich werde mir die Pivot Tabellen mal anschauen. 

Viele Grüße
Lucas
Antwortento top
#6
Hab ne Lösung gefunden, danke an alle!
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste