Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

SUMMENPRODUKT mit leeren Zellen
#1
Hallo zusammen,

ich nutze in einem Tabellenblatt eine Formel, um bestimmte "Status-Zustände" innerhalb eines benannten Bereiches zu zählen. Bei der Formel ist es mir wichtig, dass die Anzahl auch dann stimmt, wenn nur gefilterte Werte angezeigt werden. Das bekomme ich sehr gut mit den nachfolgenden Formeln dargestellt. Wie muss die Formel in "B21" lauten, wenn ich nur die leeren Zellen zählen möchte?
AB
1Status
2S
3S
4
5V
6S
7
8S
9S
10V
11V
12S
13S
14S
15S
16S
17S
18
19Status "S"11
20Status "V"3
21Status ""0
NameBezug
Status=Tabelle1!$A$2:$A$17
ZelleFormel
B19=SUMMENPRODUKT(TEILERGEBNIS(3;INDIREKT("A" & ZEILE(Status)))*(Status="S"))
B20=SUMMENPRODUKT(TEILERGEBNIS(3;INDIREKT("A" & ZEILE(Status)))*(Status="V"))
B21=SUMMENPRODUKT(TEILERGEBNIS(3;INDIREKT("A" & ZEILE(Status)))*(Status=""))
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg


Angehängte Dateien
.xlsx   Summenprodukt mit leeren Zellen.xlsx (Größe: 16,72 KB / Downloads: 6)
Herzliche Grüße aus dem Rheinland
Jörg

[Windows 10, Microsoft 365]
Antwortento top
#2
Hallo Joe,

warum so ein Aufwand? So geht es:
Tabelle2

AB
1Status
2S
3S
4
5V
6S
7
8S
9S
10V
11V
12S
13S
14S
15S
16S
17S
18
19Status "S"11
20Status "V"3
21Status ""2
Formeln der Tabelle
ZelleFormel
B19=SUMMENPRODUKT((A$2:A$17="S")*1)
B20=SUMMENPRODUKT((A$2:A$17="V")*1)
B21=SUMMENPRODUKT((A$2:A$17="")*1)

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Viele Grüße
Klaus-Dieter
Der Erfolg hat viele Väter, 
der Misserfolg ist ein Waisenkind
Richard Cobden
[-] Folgende(r) 1 Benutzer sagt Danke an Klaus-Dieter für diesen Beitrag:
  • LuckyJoe
Antwortento top
#3
ungetestet (Vorschlag, weiß nicht, ob's geht):

B21: =SUMMENPRODUKT(TEILERGEBNIS(3;INDIREKT("A" & ZEILE(Status)))*(0&Status="0"))
[-] Folgende(r) 1 Benutzer sagt Danke an LCohen für diesen Beitrag:
  • LuckyJoe
Antwortento top
#4
Moin

Mit TEILERGEBNIS(3;...) kann das nicht funktionieren weil das für die Funktion ANZAHL2() steht.
Versuch mal ANZAHL2() auf ein leere Zelle anzuwenden.
Eine Websuche hat ergeben dass es mit einer zusätzlichen Spalte funktioniert, die in jeder Zeile einen Wert hat.
Beispiel.
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
[-] Folgende(r) 1 Benutzer sagt Danke an shift-del für diesen Beitrag:
  • LuckyJoe
Antwortento top
#5
Hallo,

@Klaus-Dieter: Danke, die Formel ist mir bekannt, aber die berücksichtigt halt nicht gefilterte Werte: würde ich z.B. nach "S" filtern, müsste bei Status = "" 0 herauskommen.

@LCohen: Danke auch dir, aber das funktioniert nicht, auch wenn ich die Formel ändere auf
B21: =SUMMENPRODUKT(TEILERGEBNIS(3;INDIREKT("A" & ZEILE(Status)))*(0 & Status=""))
Herzliche Grüße aus dem Rheinland
Jörg

[Windows 10, Microsoft 365]
Antwortento top
#6
Diese Formel habe ich Dir nie gegeben. Schreibst Du Tipps etwa ab (statt zu kopieren)? - Meine Formel ist aber trotzdem falsch.
Antwortento top
#7
Moin Jörg,

ich bin mir jetzt nicht ganz sicher, ob ich dich richtig verstanden habe; leere Zellen kannst du doch mit ANZAHLLEEREZELLEN() ermitteln. Es werden auch die leeren Zellen (alle!) eines Bereichs angezeigt, wenn dieser gefiltert ist.

Bereich ungefiltert:
Arbeitsblatt mit dem Namen 'Tabelle1'
AB
1Überschrift3
2S
3V
4
5V
6V
7S
8S
9
10V
11S
12
13V
14S
15S
16V

ZelleFormel
B1=ANZAHLLEEREZELLEN(A1:A16)
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg

Bereich nach V gefiltert:
Arbeitsblatt mit dem Namen 'Tabelle1'
AB
1Überschrift3
3V
5V
6V
10V
13V
16V
17

ZelleFormel
B1=ANZAHLLEEREZELLEN(A1:A16)
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Günter
Jeder Fehler erscheint unglaublich dumm,
wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
[-] Folgende(r) 1 Benutzer sagt Danke an WillWissen für diesen Beitrag:
  • LuckyJoe
Antwortento top
#8
Klaus-Dieter und WillWissen: Es geht um Nichtberücksichtigung ausgeblendeter Zeilen.
Antwortento top
#9
Hallo,

@LCohen: ich hatte deine Formel kopiert und getestet: funktioniert nicht, was ich dir mit dem Satz "Danke auch dir, aber das funktioniert nicht" mitgeteilt habe.
Daraufhin habe ich deine Formel abgeändert (weil in "Status" keine "0" vorkommen kann) und dir mitgeteilt "auch wenn ich die Formel ändere auf ..." und dann o.g. Formel eingestellt.

@shift-del: Danke dir, das klappt wie in deinem verlinkten Beispiel gezeigt wie gewünscht! Da in meiner Tabelle andere Spalten vorhanden sind, die immer gefüllt sind, kann ich die Formel entsprechend anpassen. Damit habe ich für dieses Thema die gewünschte Lösung.

@Günter: Danke auch dir, aber bei der Filterung der Tabelle will ich gerade zählen, wieviel leere Zellen (in den gefilterten Daten) noch vorhanden sind (die Filterung erfolgt in einer anderen Spalte).
Herzliche Grüße aus dem Rheinland
Jörg

[Windows 10, Microsoft 365]
Antwortento top
#10
(07.06.2020, 11:54)LuckyJoe schrieb: @LCohen: ich hatte deine Formel kopiert und getestet: funktioniert nicht, was ich dir mit dem Satz "Danke auch dir, aber das funktioniert nicht" mitgeteilt habe.
Daraufhin habe ich deine Formel abgeändert (weil in "Status" keine "0" vorkommen kann) und dir mitgeteilt "auch wenn ich die Formel ändere auf ..." und dann o.g. Formel eingestellt.

Meine Antwort ist falsch; das habe ich hinterher geschrieben. Ich hatte aber vorher auch geschrieben: Ungetestet.

Wenn ich aber (0&Status="0") schreibe, dann ist das Ernst. Denn dann wird "0" statt "0S" oder "0V" ausgewertet, und Du kommst um Leerzellen herum. Hat hier leider nicht funktioniert - ich war zu faul, es selbst zu testen. Außerdem: shift-del's richtiger Hinweis mit der Funktion.
[-] Folgende(r) 1 Benutzer sagt Danke an LCohen für diesen Beitrag:
  • LuckyJoe
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste