Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

SUMME Formel, dabei Jahreswerte auslassen
#1
Hallo zusammen,

nochmal eine kurze Frage.

Ich habe über mehrere Jahre Werte pro Monat. Dann habe ich mir mit der Summen Formel entsprechend die Summe berechnet. Wenn ich aber die Formel über die Spalten langziehe, ändert sich natürlich die Summe. So soll es auch sein. Nun habe ich dort aber auch Jahreswerte, die die Formel nicht einrechnen darf. Kann man diese Jahreswerte einfach ausklammern oder muss ich immer händisch die Summenformel anpassen (d.h. Summe(...)+Summe(...)?

Danke für eure Hilfe
Antwortento top
#2
Hallo,

zeig mal bitte einen relevanten Tabellenausschnitt mit dem Tool oder eine kleine Beispieldatei incl. deiner Berechnungen. Keine Bildchen. https://www.clever-excel-forum.de/Forum-...gshinweise
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#3
Hier das Beispiel. Die Spalten AM & AO

DankeSmile


Angehängte Dateien
.xlsx   Mappe5.xlsx (Größe: 9,43 KB / Downloads: 5)
Antwortento top
#4
Hallöchen,

nutze SUMMENPRODUKT

z.B. zum Rechnen der 2. und 4. Spalte

Arbeitsblatt mit dem Namen 'Tabelle1'
ABCD
11234
26

ZelleFormel
A2=SUMMENPRODUKT((A1:D1)*(REST(SPALTE(A1:D1);2)=0))
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.2) erstellt. ©Gerd alias Bamberg

Der Rest ist Mathe. Schaue, dass Dir jede 13. oder wievielte Spalte auch immer nicht gerechnet wird.

im Prinzip so was wie REST(SPALTE();13)<>0 und ggf. noch einem Versatz wenn Du nicht in Spalte A anfängst.
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#5
Hallo schauan,

danke dir deine HilfeSmile

Kann man das auch mit festen Spalten machen?

Da die Summe von Monat zu Monat variiert (immer die vorherigen 24 Monate), ist z.B. die 13. Spalte ja immer eine andere.

Viele Grüße

Carolin

Ich habe jetzt eine Lösung gefunden. Danke dir nochmal
Ich habe jetzt alle Jahresspalten mit einem x gekennzeichnet.
Antwortento top
#6
Hallo, ich habe das so verstanden..:

Arbeitsblatt mit dem Namen 'Tabelle1'
AB
8Summe666
9666

ZelleFormel
B8=SUMME(INDEX(B6:AO6;N(WENN(1;{13.26.39}))))
B9=SUMMEWENN(B5:AO5;"<2100";B6:AO6)
Verwendete Systemkomponenten: [Windows (32-bit) NT 6.02] MS Excel 2010
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Jörg

"Wer immer tut, was er schon kann, bleibt immer das, was er schon ist." - Henry Ford
Antwortento top
#7
Hallöchen,

wie gesagt, geht auch mit meiner Variante  … Die Formel mit <> 0 braucht die Zwischensummen nicht und berücksichtigt schon den Januar 23

Wenn Du nicht jeden Jahreswert willst, z.B. 2022 weglassen, wäre es bei mir
=SUMMENPRODUKT((B6:FF6)*(REST(SPALTE(B6:FF6)-1;13)=0)*(SPALTE(B6:FF6)<>27))

oder mit der Formel von Jörg
=SUMME(INDEX(B6:AO6;N(WENN(1;{13.39}))))

oder eben Deine einfache "x"-Lösung Smile wo Du ohne Formeländerung auskommst falls ein x mal anders oder in 3 Jahren neu gesetzt werden muss

Arbeitsblatt mit dem Namen 'Tabelle1'
AB
8Summe666
9703

ZelleFormel
B8=SUMMENPRODUKT((B6:FF6)*(REST(SPALTE(B6:FF6)-1;13)=0))
B9=SUMMENPRODUKT((B6:FF6)*(REST(SPALTE(B6:FF6)-1;13)<>0))
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.2) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste