Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Recordset und Array
#1
Hallo zusammen,

weiss zufällig jemand warum ein von einer geschlossenen Tabelle mit ADO ausgelesener Recordset welcher an einen Array übergeben wird falsche Daten ausgibt. Der Array ist variant. Im ersten Feld (Spalte1,Zeile3) ist eine Nummerierung dann kommen Namen in Spalte2 danach sollen Daten als Buchstaben eingefüllt werden. In Zeile 1 und 2 sind Datumswerte (TTT u. TT)
Nun soll der Array ab Zelle 4.4 quasi die Buchstaben eintragen ,dies klappt auch ab Index 6.4 einwandfrei jedoch zuvor füllt der Array sich mit den verschiedensten Daten
Antworten Top
#2
Ein paar Angaben mehr wären gut:
Welcher Wert steht in der Ursprungstabelle, was steht dann im Array?

Wenn es um Datumswerte geht, die lediglich mit einem Format belegt sind (TTT oder TT), dann ist der Ursprungswert eine Zahl. Stell mal die Datumsfelder in der Quelle auf das Zahlenformat "Standard" und vergleiche das mit der Ausgabe des Arrays.
[-] Folgende(r) 1 Nutzer sagt Danke an Gast für diesen Beitrag:
  • Wedelwuff
Antworten Top
#3
Danke für den Tipp, war zwar nicht die Ursache, aber in der Original Tabelle sind Formeln die einen Wert als Buchstabe zurückliefern. Versehentlich hatte ich hier in den ersten Spalten die Formeln zu Testzwecken entfernt und vergessen die Formeln wieder einzufügen. Die Buchstaben wurden daher nicht im Recordset übernommen. Jetzt läuft es.
Antworten Top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste