Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Obergrenze in 0,5 Schritten
#1
Hi zusammen,

ich brauch mal wieder eure Hilfe :)

Mit dieser Formel "=OBERGRENZE(SUMME(T2:AB2);0,5)" runde ich in 0,5er Schirtte Zahlen auf mit 2 Nachkommastellen. DAs funktioniert auch super.
Ich würde aber gern, dass dies erst geschiegt, wenn die zwei Nachkommastelle größer als 54 ist amsonsten runter runden.

Als Beispiel, links Quellgewicht, rechts Zielgewicht
1,10 = 1,50
1,54 = 1,50
1,55 = 2,00
1,56 = 2,00

Wie kann ich das die Formel entsprechend anpassen?

Vielen DAnk im Voraus
LG, Alexandra
Antworten Top
#2
Hallo,

ich gehe davon aus diese Regel gilt auch bei 1,04 bzw. 1,05 ...
=OBERGRENZE( A2 - 0,04; 0,5 )

Gruß Sigi
Antworten Top
#3
Hallo Sigi,

logischer Weise sollte es auch bei 1,04 oder 1,05 gelten, tut es aber leider nicht. Warum? Kann nun unser Spediteur beantworten?
Wie kann ich dein Formel anpassen, dass es bei der 1,04 und 1,05 nicht greift?

DAnke & LG, Alexandra
Antworten Top
#4
Hallo,

was soll aus 1,01, 1,03, ... dann werden? Etwa 1,50?

Gruß Sigi
Antworten Top
#5
Hallo,
meinst du so?

MfG Günter

.xlsx   Obergrenze.xlsx (Größe: 15,45 KB / Downloads: 8)
Win 11, Office 2021
Wenn Thema gelöst, dann bitte kennzeichnen.

Wer aufgibt, hat schon verloren.
Antworten Top
#6
Hallo Sigi,

ja, aus 1,01, 1,02, 1,03 soll 1,5 werden. Ich weiß das ist nicht logisch aber ist leider so....

@Günter, deine Formel funktioniert aber nur bis 2kg, danach nicht mehr ;) ?

Die Tabelle geht bis 1000kg...

Vielen Dank im Voraus
LG, Alexandra
Antworten Top
#7
Hallo Alexandra,

dann sollte es so gehen ...

=WENN( REST(A2 *100; 100) < 10; OBERGRENZE(A2; 0,5); OBERGRENZE(A2-0,04; 0,5) )

Gruß Sigi
Antworten Top
#8
Hallo Sigi,

suuuuper, das funktioniert perfekt! :)

Vielen herzlichen Dank
LG, Alexandra
Antworten Top
#9
Oder ?

PHP-Code:
=CEILING(A2-(MOD(A2;1)<0,55)*0,04;0,5
Zum übersetzen von Excel Formeln:

http://dolf.trieschnigg.nl/excel/index.p...gids=en+de
Antworten Top
#10
Hallo snb,

Danke, das funktioniert aber nicht bei 1,01 bis 1,04 z.B., da bleibt es bei 1 ? 

LG, Alexandra
Antworten Top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste