Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Nummerierung und doppelte Verlinkung
#1
Hallo Leute,
ich bin gerade dabei einen Backupversionsverlauf zu erstellen und bin dabei auf zwei Probleme gestoßen.
Beide sind in der angehängten Datei im zweiten Tab zu sehen.

Problem 1: Ich möchte eine fortlaufende Nummerierung abhängig von den Werten in einer anderen Spalte generieren.
Also in einer Spalte habe ich zum Beispiel drei Geräte (auswählbar aus einem DropdownMenu). Und zu jedem der Geräte möchte ich in einer anderen Spalte eine fortlaufende Nummerierung, die sich automatisch erstellt. Als Beispiel:

Geräte:         Nummerierung (Version):
Gerät A         1
Gerät A         2
Gerät A         3
Gerät B         1
Gerät C         1
Gerät C         2
Gerät A         4
Gerät C         3
Gerät A         5
Gerät B         (2)
Die Auswahl von "Gerät B" in der letzten Zeile soll die "2" automatisch generieren. Ist das möglich?

EDIT: Problem 1 konnte ich lösen:
=WENN($B10=$C$2;ZÄHLENWENN($B$8:$B10;$C$2);WENN($B10=$C$3;ZÄHLENWENN($B$8:$B10;$C$3);WENN($B10=$C$4;ZÄHLENWENN($B$8:$B10;$C$4);"")))

Problem 2: Die Geräte sind in einer anderen Tabelle mit Spitznamen verknüpft.
Ich generiere einen Backupnamen aus Datum, Gerät, Personalnr und Version. Statt dem Gerätenamen hätte ich allerdings gerne den Spitznamen im generierten Backupnamen.
Zelle F10 im zweiten Tab meiner Datei sollte also zum Beispiel "VAT1_HMI_20201112_234_002" heißen. Ich bekomme die Verknüpfung allerdings nicht hin...

Danke im Vorraus
LG Stogi


Angehängte Dateien
.xlsx   SPS Änderungsverlauf.xlsx (Größe: 30,11 KB / Downloads: 4)
Antwortento top
#2
Hallöchen,

ohne die Datei angeschaut zu haben - erstelle eine Liste mit der Zuordnung zu den Spitznahmen und hole die Spitznamen z.B. mit SVERWEIS in Abhängigkeit der Namen aus dieser Liste
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste