Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Neue Excel Formeln Teil 1
#1
Hallo,

hier einmal für die Unwissenden die Neuen Excel Formeln - Teil 1.
Es fehlt noch Sortieren und Sortierennach.
Diese Beispiele gibt es auf meiner Homepage noch nicht, da das Forum vorgeht:


Tabelle1

ABCD
1Dieses Beispiel wurde für
2http://ms-excel.eu
3erstellt
4 =Filter()
5xgesuchter Name:Ahrens, Jörg
6Ahrens, Jörg44
7Gregor, udo26
8Koch, Fred3
9Ahrens, Jörg6
10Summe:10
11
12
13
14xAhrens, Jörg
15Summe:10
Formeln der Tabelle
ZelleFormel
D6=FILTER(B6:B9;A6:A9=D5)
D10=SUMME(D6:D9)
B14=D5
B15=SUMME(FILTER(B6:B9;A6:A9=B14))

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8


Tabelle1

ABCDE
1Dieses Beispiel wurde für
2http://ms-excel.eu
3erstellt
4 =Sequenz()
51471013
61619222528
73134374043
84649525558
96164677073
Formeln der Tabelle
ZelleFormel
A5=SEQUENZ(5;5;1;3)

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8


Tabelle1

ABCDEF
1Dieses Beispiel wurde für
2http://ms-excel.eu
3erstellt
4=ZUFALLSMATRIX(3;6;1;49;WAHR)
536,37396025,4314973635,304548823,682983243,782553545,1308658
6
71974273818
847441548138
922542484934
Formeln der Tabelle
ZelleFormel
A4=FORMELTEXT(A7)
A5=ZUFALLSMATRIX(1;6;1;49;FALSCH)
A7=ZUFALLSMATRIX(3;6;1;49;WAHR)

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8



Tabelle1

ABCDEFGH
1Dieses Beispiel wurde für
2http://ms-excel.eu
3erstellt
4 =Eindeutig()
5Namen einzeln auflistendoppelte werden ausgelassenwird 1:1 übertragen
6Name 11Name 1Name 2Name 1
7Name 22Name 2Name 3Name 2
8Name 13Name 3Name 4Name 1
9Name 34Name 4Name 3
10Name 4Name 4
Formeln der Tabelle
ZelleFormel
D6=EINDEUTIG(A6:A10;FALSCH;FALSCH)
F6=EINDEUTIG(A6:A10;FALSCH;WAHR)
H6=EINDEUTIG(A6:A10;WAHR;FALSCH)

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8


Liebe Grüße
Marcus

Ich arbeite mit Excel 2003 - Excel 2007 - Excel 365

Homepage im Aufbau (alte Daten müssen wieder hergestellt werden): http://ms-excel.eu

Wissen ist Macht - es ist aber nicht schlimm nicht alles zu wissen.
Man muss nicht alles wissen - man muss nur wissen wo es steht, oder wo man Hilfe bekommt.

Antwortento top
#2
Netter Beitrag marose67,

wichtig ist imho auch XVERWEIS() und XVERGLEICH().

Und die Möglichkeiten dynamischer Arrays!

BG ruppy
[-] Folgende(r) 1 Benutzer sagt Danke an ruppy für diesen Beitrag:
  • marose67
Antwortento top
#3
(19.02.2020, 14:05)ruppy schrieb: Netter Beitrag marose67,
wichtig ist imho auch XVERWEIS() und XVERGLEICH().
...
BG ruppy

Hallo, du hast den Betreff gelesen..?
Gruß Jörg

"Wer immer tut, was er schon kann, bleibt immer das, was er schon ist." - Henry Ford
Antwortento top
#4
Hallo Jörg,

ruppy hat recht. Habe ich vergessen zu erwähnen und zum Teil vergessen einzustellen. Ich hoffe das morgen Teil 2 folgen kann. Ich bin nicht so schlau, wie ihr es seit. Ich arbeite dran...

Hier der xverweis:

Tabelle1

ABCDEFGH
1Dieses Beispiel wurde für
2http://ms-excel.eu
3erstellt
4 =Xverweis()
5NameStrassePers. Nr:Wohnort6Name7OrtStrasse
6Name1Strasse11Ort1Name6Ort6Strasse6
7Name2Strasse22Ort2
8Name3Strasse33Ort3
9Name4Strasse44Ort4Ort3
10Name5Strasse55Ort5Ort1
11Name6Strasse66Ort6
12Name7Strasse77Ort7
Formeln der Tabelle
ZelleFormel
F6=XVERWEIS(E5;C6:C12;A6:A12;"nicht gefunden";0)
G6=XVERWEIS(E5;C5:C12;D5:D12;"nicht gefunden";0)
H6=XVERWEIS(E5;C5:C12;B5:B12;"nicht gefunden";0)
F9=XVERWEIS("Name3Strasse3";A6:A12&B6:B12;D6:D12;"nicht gefunden";0)
F10=XVERWEIS("Name1Strasse1";A6:A12&B6:B12;D6:D12;"nicht vorhanden";0)

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

Gruß
Marcus

Ich arbeite mit Excel 2003 - Excel 2007 - Excel 365

Homepage im Aufbau (alte Daten müssen wieder hergestellt werden): http://ms-excel.eu

Wissen ist Macht - es ist aber nicht schlimm nicht alles zu wissen.
Man muss nicht alles wissen - man muss nur wissen wo es steht, oder wo man Hilfe bekommt.

Antwortento top
#5
Hi Marcus, ist doch egal, wann Teil zwei kommt. Wenn im Betreff Teil 1 steht, gehe ich davon aus, dass da noch was kommt.
Gruß Jörg

"Wer immer tut, was er schon kann, bleibt immer das, was er schon ist." - Henry Ford
[-] Folgende(r) 1 Benutzer sagt Danke an Jockel für diesen Beitrag:
  • marose67
Antwortento top
#6
Ein schönes Beispiel für SEQUENZ() wäre ein Kalender... (könnte ich heute abend mal reinstellen...)
Gruß Jörg

"Wer immer tut, was er schon kann, bleibt immer das, was er schon ist." - Henry Ford
Antwortento top
#7
Hallo Jörg,
würde mich persönlich mal interessieren.

Gruß und Dank
Marcus

Ich arbeite mit Excel 2003 - Excel 2007 - Excel 365

Homepage im Aufbau (alte Daten müssen wieder hergestellt werden): http://ms-excel.eu

Wissen ist Macht - es ist aber nicht schlimm nicht alles zu wissen.
Man muss nicht alles wissen - man muss nur wissen wo es steht, oder wo man Hilfe bekommt.

Antwortento top
#8
Hi Marcus, hier (m)ein Vorschlag..:

Arbeitsblatt mit dem Namen 'SEQUENZ_Kalender'
ABCDEFG
120202
2
3MoDiMiDoFrSaSo
427.0128.0129.0130.0131.0101.0202.02
503.0204.0205.0206.0207.0208.0209.02
610.0211.0212.0213.0214.0215.0216.02
717.0218.0219.0220.0221.0222.0223.02
824.0225.0226.0227.0228.0229.0201.03
902.0303.0304.0305.0306.0307.0308.03

ZelleFormel
A3=TEXT(A4;"TTT")
B3=TEXT(B4;"TTT")
C3=TEXT(C4;"TTT")
D3=TEXT(D4;"TTT")
E3=TEXT(E4;"TTT")
F3=TEXT(F4;"TTT")
G3=TEXT(G4;"TTT")
A4=SEQUENZ(6;7;DATUM(A1;B1;1)-WOCHENTAG(DATUM(A1;B1;1);3))

Zellebedingte Formatierung...Format
A51: MONAT(A5)<>$B$1abc
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg

... und ich finde bei EINDEUTIG() ein Beispiel verknüpft mit SORTIEREN() schöner...

Arbeitsblatt mit dem Namen 'Blatt1'
ABC
1NameName
2Koch, FredAhrens, Jörg
3Ahrens, JörgGregor, Udo
4Gregor, UdoKoch, Fred
5Ahrens, Jörg

ZelleFormel
C2=EINDEUTIG(SORTIEREN(Tabelle2[Name];;1))
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Jörg

"Wer immer tut, was er schon kann, bleibt immer das, was er schon ist." - Henry Ford
[-] Folgende(r) 1 Benutzer sagt Danke an Jockel für diesen Beitrag:
  • marose67
Antwortento top
#9
Hallo zusammen,

@Jörg: Das EIndeutig(Sortieren()) hatte ich für Teil 2 hinterlegt. OK ... Jetzt hast Du es gezeigt.
@all:
hier noch ein Nachtrag zum Xverweis()

Tabelle1

ABCDEFGH
14 =Summe(xverweis();xverweis())
15NameAnzahl
16Name13Name1
17Name26Name75
18Name35
19Name44
20Name51
21Name61
22Name72
Formeln der Tabelle
ZelleFormel
E17=SUMME(XVERWEIS(D16;A16:A22;B16:B22);XVERWEIS(D17;A16:A22;B16:B22))

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

Gruß
Marcus

Ich arbeite mit Excel 2003 - Excel 2007 - Excel 365

Homepage im Aufbau (alte Daten müssen wieder hergestellt werden): http://ms-excel.eu

Wissen ist Macht - es ist aber nicht schlimm nicht alles zu wissen.
Man muss nicht alles wissen - man muss nur wissen wo es steht, oder wo man Hilfe bekommt.

Antwortento top
#10
Hallo,
hier noch ein Beispiel zum XVERWEIS()

Tabelle1

ABCDEF
13 =Xverweis()
14Pers. Nr.:Name:Verkauft:Bonus:850
151111Ronsdorf, Ronald1.150,00 €Wuppi, Wolfgang
161112Wuppi, Wolfgang950,00 €
171113Düssel, Detlef1.300,00 €
181114Dortmunder, Dora800,00 €
Formeln der Tabelle
ZelleFormel
F15=XVERWEIS(F14;C15:C18;B15:B18;"Nicht gefunden";1)

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

Wie ihr seht, werden Fehlermeldungen direkt abgefangen. Man gibt es in der Formel mit ein.
Gruß
Marcus

Ich arbeite mit Excel 2003 - Excel 2007 - Excel 365

Homepage im Aufbau (alte Daten müssen wieder hergestellt werden): http://ms-excel.eu

Wissen ist Macht - es ist aber nicht schlimm nicht alles zu wissen.
Man muss nicht alles wissen - man muss nur wissen wo es steht, oder wo man Hilfe bekommt.

Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste