Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Namensliste
#1
Hallo alle zusammen,

ich habe mal wieder ein kleines Problem.
Ich habe eine Tabelle für Tresendienst, unsere Paare haben eine Nummer und natürlich Ihre Namen.

In der Tabelle Liste würde ich in Spalte A gern die Nummer eingeben
und in Spalte B sollte der Name aus der Tabelle Mannschaft selbst erscheinen.

Könnt Ihr mir da Bitte helfen?!

Grüße

Und ja ich Arbeite teilweise, wegen anderen mit Benutzern mit OpenOffice 22


Angehängte Dateien
.ods   Tresenliste-2024-2.ods (Größe: 21,6 KB / Downloads: 4)
.xls   Tresenliste-2024-2.xls (Größe: 22,5 KB / Downloads: 11)
Antworten Top
#2
Hallo,

In Zelle B3 des ersten Blattes nach unten ausfüllen:

=WENNFEHLER(SVERWEIS(A3;Mannschaft!$A$3:$B$16;2;FALSCH);"")

Sollte auch mit OpenOffice funktionieren...

Was ist mit dem zweiten Blatt? Da müsste nur in die eine Zelle A3 die Formel 

=SORTIEREN(Liste!$A$3:$D$79;1)

Und vielleicht die Tabelle "Sortiert nach Paar" um ein paar Zeilen nach unten erweitern, sonst läuft sie über...
Antworten Top
#3
Leider schmeißt er mir da den Fehler #NAME?
Huh
Antworten Top
#4
(19.05.2024, 12:18)19Seb schrieb: Leider schmeißt er mir da den Fehler #NAME?
Huh

Hast du die Formel von mir kopiert und eingefügt oder abgetippt? #NAME deutet darauf hin, dass eine Funktion nicht existiert (Tippfehler in "WENNFEHLER?")
Antworten Top
#5
Hi,

formeln für .ods:

Sverweis:

Code:
=SVERWEIS(A3;$Mannschaft.A:B;2;0)

Was soll wo sortiert werden?

Hier mal die überarbeitete Tabelle:


.ods   Tresenliste-2024-2.ods (Größe: 34,5 KB / Downloads: 4)

@Sabotaz,

1. gibt es die Funktionen Sortieren usw. nur in neueren Excelversionen, und da auch nicht in jeder,
2. gibt es sie in OpenOffice garnicht und die Syntax ist in OO auch eine andere.
3. #Name deutet eben darauf hin, dass es die Funktion nicht gibt.
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
[-] Folgende(r) 1 Nutzer sagt Danke an BoskoBiati für diesen Beitrag:
  • Sabotaz
Antworten Top
#6
(19.05.2024, 12:33)BoskoBiati schrieb: @Sabotaz,

1. gibt es die Funktionen Sortieren usw. nur in neueren Excelversionen, und da auch nicht in jeder,
2. gibt es sie in OpenOffice garnicht und die Syntax ist in OO auch eine andere.
3. #Name deutet eben darauf hin, dass es die Funktion nicht gibt.

"Sortiert nach Paar" heißt das Blatt. Daher wäre es sinnvoll, nach Nummer oder eben nach Namen zu sortieren. Nach Nummer dann noch eher.

Gut zu wissen! Ich wusste, dass es SORTIEREN nicht schon ewig gibt, aber dass sie so neu ist, hätte ich nicht gedacht. Dann ist die Funktion spezieller als ich geahnt hätte. 3. Wäre dann meine letzte Vermutung gewesen, wenn 19Seb die Formel hier herauskopiert hätte.

Ach und: ich ging davon aus, dass die erste Formel bereits fehlerhaft ist, die zweite war ja nur so in den Raum geschmissen. Das hat 19Seb leider nicht dazugeschrieben, welche Formel jetzt #NAME? betrifft
Antworten Top
#7
Hi Sabotaz,

1. mußt Du keinen Full-Quote meines Beitrags machen.
2. interessiert mich eher, was der TE zum Thema sortieren meint, als das, was Du Dir vorstellst, zumal das noch garnicht angefragt war.
3. kann man in der Hilfe sehen, in welchen Versionen eine Funktion gültig ist. Allerdings hat der TE eine OO-Version angegeben.
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antworten Top
#8
Iwie
funktioniert bei mir garnix, egal welche Formel ich da eingebe  Undecided
Antworten Top
#9
Hi,

in meiner Datei sind die benötigten Formel schon drin, was funktioniert da nicht?
Wo gibst Du welche Formeln ein?
Welche Excelversion hast Du?
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antworten Top
#10
Hallo Seb,

mit dem Vorschlag von Sabotaz sollte es auch bei dir funktionieren, es sei denn deine Excelversion liegt vor 2007.
Das Sortieren im 2. Blatt solltest du noch mal präzisieren. Wäre es so zu verstehen wie von mir im Blatt 1 angedeutet?

Für die OO - Nutzer musst du wahrscheinlich eine eigene Datei erstellen. (In Libre Office würde die andere Formel von Edgar funktionieren)

Freundliche Grüß Rudi' S


Angehängte Dateien
.xls   Tresenliste-2024-2.xls (Größe: 45,5 KB / Downloads: 2)
Antworten Top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste