Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Nach mehreren Angaben suchen lassen
#1
Hallo zusammen,

wie müsste die Formel lauten, wenn ich z.b auch noch nach "901" und "930" suchen lassen will.

=WENNFEHLER(TEIL(A3;FINDEN("925";A3)+0;13);D2)

Solange nichts anderes gefunden wird in den Zeilen, soll es immer die Zeile darüber kopieren, Daher "D2"

   

In Spalete A stehen Angaben und wenn dort "901" und oder "925" und oder "930" gefunden wird, dann schreibe die Artikelnummer in spalte D. Und wenn nicht gefunden wird, nimm den Wert von darüber mit.


Danke schön

Gruß Philipp
Antworten Top
#2
Moin,

mal "nur" mit 901 zusätzlich:
Code:
=WENNFEHLER(TEIL(A3;FINDEN("925";A3)+0;13);WENNFEHLER(TEIL(A3;FINDEN("901";A3)+0;13);D2))

EDIT:

Wenn dein Schema (+0;13) immer identisch ist kannst du dir die Verschachtelung auch sparen und stattdessen mit Finden(Oder( arbeiten.
Gruß

Stoffo
Antworten Top
#3
Vielen lieben Dank!

So habe ich die Formel mir auch geschrieben aber irgendwie hat es da nicht geklappt gehabt...Weiß auch nicht warum...

So hier wie ich es brauch :)

Code:
=WENNFEHLER(TEIL(A3;FINDEN("925";A3)+0;13);WENNFEHLER(TEIL(A3;FINDEN("901";A3)+0;13);WENNFEHLER(TEIL(A3;FINDEN("930";A3)+0;13);D2)))

Gruß Philipp
Antworten Top
#4
Hi,

wenn deine Nummern immer genau so aufgebaut sind:
xxxxxxx 901-xxxxx
xxxxxxx 925-xxxxx
xxxxxxx 930-xxxxx
Dann kannst du auch einfach nach dem ersten "-"-Zeichen suchen lassen:
=WENNFEHLER(TEIL(A3;FINDEN("-";A3)-3;13);D2)

Wenn deine Nummern immer mit "8425383 40 " beginnen, dann funktioniert auch
=WENN(LINKS(A3;11)="8425383 40 ";TEIL(A3;12;13);D2)
Analog könntest du auch immer den rechten Teil prüfen lassen, falls der immer gleich ist.
Gruß,
Helmut

Win10 - Office365 / MacOS - Office365
Antworten Top
#5
Vielen Dank für deine Antwort.

Der erste Teil ist leider immer unterschiedlich. In der Zeile könnten noch weitere "-" auftauchen.

Daher bleibt mir glaub ich nur nach "925" "901" "930" suchen übrig.

Schönes Wochenende

Philipp
Antworten Top
#6
Hi,

wenn es immer das erste "-" ist, dann funktioniert es!
Ansonsten bring mal ein paar handfeste Beispiele und vor allem bitte nicht als Bild, sondern als Excel-Datei. Dann kann man eher Gemeinsamkeiten feststellen. Und wer garantiert dir, dass z.B. "925" sonst nirgends vorkommt? Wäre es nicht eindeutiger nach " 925-" zu suchen?
Gruß,
Helmut

Win10 - Office365 / MacOS - Office365
Antworten Top
#7
Das mit den 925- ist ein super Hinweis - Der wird auch gleich berücksichtigt.

Das nächste Mal, wenn ich wieder Hilfe benötige, lade ich dann eine Excel-File hoch.

Vielen Dank
Antworten Top
#8
Kann noch immer in diesem thread.

Wahrscheinlich reicht:

PHP-Code:
=Mid(A1;12;12
Zum übersetzen von Excel Formeln:

http://dolf.trieschnigg.nl/excel/index.p...gids=en+de
Antworten Top
#9
Leider nein.

Code:
8425383 40 925-1020-001 499226 30413528 2.1 20377E

könnte bei einem anderen Kunde so lauten


Code:
8425.10 925-1010-001 499226 30413528 2.1 20377E

Mit der Anfangsformel ist mir echt geholfen und mit dem Tipp die 925- zu konkretisieren noch besser :)
Code:
=WENNFEHLER(TEIL(A3;FINDEN("925-";A3)+0;13);WENNFEHLER(TEIL(A3;FINDEN("901-";A3)+0;13);WENNFEHLER(TEIL(A3;FINDEN("930-";A3)+0;13);D2)))
Danke
Antworten Top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste