Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

#NV als 0 ausgeben
#1
Hallo zusammen,

ich habe ein Problem mit folgender Formel:

=SUMME(BEREICH.VERSCHIEBEN(INDEX(Brutto!B:B;VERGLEICH(B39;Brutto!B:B;0));-365;4;365;1))

wenn der Vergleich nicht gefunden wird, wird #NV ausgegeben was mir die komplette Tabelle zerlegt...
soweit verstehe ich das noch

ich bekomme es nur nicht hin, dass statt #NV dann einfach eine 0 ausgegeben wird...

soweit ich weiß müsste das doch so gehen:

=WENN(ISTNV(BEREICH.VERSCHIEBEN(INDEX(Brutto!B:B;VERGLEICH(B39;Brutto!B:B;0));-365;4;365;1));0;(BEREICH.VERSCHIEBEN(INDEX(Brutto!B:B;VERGLEICH(B39;Brutto!B:B;0));-365;4;365;1)))

dabei gibt der mir aber immer eine 0 aus... auch wenn der vergleich gefunden wird und die Formel ansich ein ergebnis anzeigen würde

kann mir da jemand helfen? muss ich da vielleicht eine Matrix Formel draus machen?
[-] Folgende(r) 1 Benutzer sagt Danke an Dennis.K151 für diesen Beitrag:
  • NickL
Antwortento top
#2
Hola,

=wennfehler(DeineFormel;0)

Gruß,
steve1da
[-] Folgende(r) 2 Benutzer sagt Danke an steve1da für diesen Beitrag:
  • NickL, Dennis.K151
Antwortento top
#3
Gleiche Problem... gibt mir dauerhaft eine 0 aus...

sry hat sich erledigt... fehler gefunden... hab summe nicht mit drin gehabt

=WENNFEHLER(SUMME(BEREICH.VERSCHIEBEN(INDEX(Brutto!B:B;VERGLEICH(B39;Brutto!B:B;0));-365;4;365;1));0)

funktioniert jetzt

vielen dank
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste