Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Monatsbeträge ermitteln
#1
Moin,
in A1:A1000 steht das Buchungsdatum und in B1:B1000 der Buchungsbetrag.
In C1:C12 sollen die monatlichen Buchungssummen erscheinen.
Gruß
Dieter
Antworten Top
#2
Hallo T....

deine gesuchte Funktion ist Summewenns.
helmut

Für mich ist die Möglichkeit in Excel an Zellen und Bereichen Namen zu vergeben die wichtigste Funktionalität.
Sie macht Formeln und den VBA-code verständlicher. Für Makros gilt die Regel: "Nur über benannte Bereiche auf den Inhalt der Zellen zugreifen."
Und wofür sind Regeln da? Um nachzudenken bevor man sie bricht.





Antworten Top
#3
a) Pivottabelle mit Monatsgruppierung auf A:A
b) C1[:C12]: =SUMMEWENNS(B$1:B$1000;A$1:A$1000;">"&DATUM(JAHR(A$1);ZEILE(C1););A$1:A$1000;"<"&DATUM(JAHR(A$1);ZEILE(C2);1))
Antworten Top
#4
Moin LCohen,
das scheint zu klappen. Besten Dank. Ich muss es nur noch an meine Tabelle anpassen.
Könnt ihr mir vielleich noch sagen, wie die Formel mit =SUMMEWENNS() lauten muss?
Gruß
Dieter
Antworten Top
#5
Hallo Dieter,

1. zu
Zitat:Könnt ihr mir vielleich noch sagen, wie die Formel mit =SUMMEWENNS() lauten muss?
Welche Funktion wird den bei LCohen b) außen genutzt?

2. kürzer geht auch
=SUMMENPRODUKT($B$1:$B$1000*(MONAT($A$1:$A$1000)=ZEILE()))
helmut

Für mich ist die Möglichkeit in Excel an Zellen und Bereichen Namen zu vergeben die wichtigste Funktionalität.
Sie macht Formeln und den VBA-code verständlicher. Für Makros gilt die Regel: "Nur über benannte Bereiche auf den Inhalt der Zellen zugreifen."
Und wofür sind Regeln da? Um nachzudenken bevor man sie bricht.





Antworten Top
#6
SUMMENPRODUKT ist ein bisschen langsamer als SUMMEWENN(S).

PVT kommt bei der Geschwindigkeit am nächsten an Pivot ran: =PVT(HSTAPELN(MONAT(A1:A1000);B1:B1000);{1.6})
Antworten Top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste