Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Monat selektieren
#1
Hallo zusammen,

wenn ich eine Spalte mit einer Startzeit und eine Spalte mit einer Endezeit habe, kann ich die Werte des Monats und/oder Jahr herrausbekommen( wenn diese Tabelle über 2 Jahre gehen würde) und wenn ja wie ?

[ Bild bitte als Datei hochladen! ]

Hintergrund: Ich möchte eine Tabelle aufbauen in der ich sagen kann, in  z.B. Jan.2020 hatte ich Prod. A =xmal aus Tabelle1[Prod.A]

Gruß
Jürgen
Antwortento top
#2
Hallo Jürgen,

lad bitte eine .xlsx hoch - Bilder helfen nicht beim Helfen.
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#3
Hi,

stimmt.
Im Anhang ein Beispiel.

Gruß
Jürgen


Angehängte Dateien
.xlsx   Test.xlsx (Größe: 8,88 KB / Downloads: 9)
Antwortento top
#4
Moin

Das kann man auch ohne Formeln erkennen. Das Ergebnis ist überall 0.
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#5
Hallo,

ohne jede Kenntnis von Formeln:

Wenn man in der Spalte H die Monate bis April 2020 erweitert:

Für die Spalte I
Code:
=SUMMENPRODUKT(MONAT($A$2:$A$14)=MONAT(H7);$C$2:$C$14)

mfg
Antwortento top
#6
Hi jürgen,

Arbeitsblatt mit dem Namen 'Tabelle1'
HI
5Apr 2091

ZelleFormel
I5=SUMMENPRODUKT(MONAT(A2:A14=MONAT($H$5))*(C$2:C$14))
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
[-] Folgende(r) 1 Benutzer sagt Danke an WillWissen für diesen Beitrag:
  • JürgenRa
Antwortento top
#7
Hi WillWissen,

das Ergebniss (91) zeigt er mir nun in allen Monaten (Spalte H) an.
Es sollte das ergebniss des jeweiligen Monat angezeigt werden in den Beispiel nur unter April 2020.
(Siehe Anhang)

Gruß
Jürgen


Angehängte Dateien
.xlsx   Test.xlsx (Größe: 9,31 KB / Downloads: 13)
Antwortento top
#8
Hi Jürgen,

Formel in I2 und nach rechts und nach unten ziehen. Achtung: CSE-Abschluss!!!

Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDEFGHIJKL
1Ist StartzeitIst EndezeitProd. AProd. BProd. CProd. DProd. AProd. BProd. CProd. D
201.01.2019 05:54:0001.04.2020 06:01:001234Jan 193579
301.01.2019 05:54:0001.04.2020 06:54:002345Feb 1925303540
401.02.2019 06:54:0001.04.2020 06:55:003456Jan 2027303336
501.02.2019 06:54:0001.04.2020 06:56:004567Feb 2023252729
615.02.2019 06:56:0001.04.2020 06:57:005678Apr.2013141516
715.02.2019 06:56:0001.04.2020 06:59:006789
815.02.2019 06:56:0001.04.2020 07:08:0078910
901.01.2020 07:08:0001.04.2020 07:08:00891011
1001.01.2020 07:08:0001.04.2020 07:09:009101112
1101.01.2020 07:08:0001.04.2020 07:30:0010111213
1201.02.2020 07:30:0001.04.2020 07:34:0011121314
1301.02.2020 07:30:0001.04.2020 07:36:0012131415
1401.04.2020 07:36:0001.04.2020 07:40:0013141516

ZelleFormel
I2{=SUMME(WENN(DATUM(JAHR($A$2:$A$14);MONAT($A$2:$A$14);)=DATUM(JAHR($H2);MONAT($H2););C$2:C$14))}
Achtung, Matrixformel enthalten!
Die geschweiften Klammern{} werden nicht eingegeben.
Verlassen Sie den Zelleneditor mit Strg+Shift + Enter, statt Enter alleine.
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
[-] Folgende(r) 1 Benutzer sagt Danke an WillWissen für diesen Beitrag:
  • JürgenRa
Antwortento top
#9
Hola,

Günters Summenprodukt Formel hat Klammerfehler.
So gehts ohne CSE Abschluss:


Code:
=SUMMENPRODUKT((MONAT($A$2:$A$14)=MONAT($H2))*($C$1:$F$1=I$1)*($C$2:$F$14))

Gruß,
steve1da
Antwortento top
#10
(02.04.2020, 12:45)steve1da schrieb: Günters Summenprodukt Formel hat Klammerfehler.
So gehts ohne CSE Abschluss:

Aber das Jahr sollte doch schon mit dabei sein!? Blush

Gruß Uwe
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste