Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Mit Schaltfläche zum heutigen Datum springen
#1
Moin, moin,

ich möchte von mir sagen, dass ich im Bereich Macros schreiben, Neuland betrete.
Macros mit "aufzeichnen" und "beenden" klappt einigermaßen.
Ich möchte gern erreichen, dass ich mit einer Schaltfläche zum heutigen Datum springe.
Alle Datumseingaben stehen in C1 bis C223.
Wenn das heutige Datum z.B. in C45 steht, möchte ich auf "Knopfdruck" zu dieser Zelle wechseln.
Ich hoffe, dass ich mein Problem richtig beschrieben habe.

Viele Grüße
Hejove
Antwortento top
#2
Hi,

ich würde anstatt VBA eine Verlinkung bevorzugen:
Arbeitsblatt mit dem Namen 'Tabelle3'
ABCDE
1Datumgesuchtes Datum:28.07.202028.07.2020
220.07.2020
321.07.2020
422.07.2020
523.07.2020
624.07.2020
725.07.2020
826.07.2020
927.07.2020
1028.07.2020
1129.07.2020

ZelleFormel
D1=HEUTE()
E1=WENNFEHLER(HYPERLINK("#A"&VERGLEICH($D$1;$A$1:$A$15;0);$D$1);"Datum nicht vorhanden")
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg

Die (farbige) Hilfsspalte blendest du einfach aus. Mit Klick auf das Datum in E1 springt der Cursor in die richtige Zelle in Spalte A.
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#3
Hi,

falls es doch VBA sein soll (Datum in Spalte "C", ansonsten den Buchstaben und "Columns" anpassen):

Code:
Sub SpringZuHeute()
   
    Dim Heute As Long
   
    Heute = CDbl(Date)
    Application.GoTo reference:=ActiveSheet.Range("C" & Application.Match(Heute, ActiveSheet.Columns(3), 0)), Scroll:=True
   
End Sub
Herzliche Grüße aus dem Rheinland
Jörg

[Windows 10, Microsoft 365]
Antwortento top
#4
Hallo Günter,

ist ne schöne Sache, geht aber auch ohne Hilfsspalte:

=WENNFEHLER(HYPERLINK("#A"&VERGLEICH(HEUTE();$A$1:$A$15;0);HEUTE());"Datum nicht vorhanden")
VG, wisch
Wer Hilfe nimmt, sollte auch Hilfe geben! Auch wenn dies auf einem ganz anderm Gebiet geschieht.
Antwortento top
#5
Hi Wisch,

an die feste Verdrahtung hatte ich auch gedacht, bin dann aber zu dem geposteten Entschluss gekommen, weil dieser etwas flexibler ist, falls der TE auch x-beliebige Daten aufrufen will. Die Forumserfahrung lehrt einfach, dass nach Vorstellung einer Lösung oftmals (weitere) Begierlichkeiten kommen.

In so einem Fall darf natürlich die Hilfsspalte nicht ausgeblendet werden.
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#6
Moin,
danke für eure schnellen Antworten. Ich habe mal die Formel von Günter ausprobiert.
=WENNFEHLER(HYPERLINK("#A"&VERGLEICH(HEUTE();$A$1:$A$15;0);HEUTE());"Datum nicht vorhanden")
Meine Daten (Datum) stehen in C8-67, das heutige Datum aus der v.g. Formel soll in D3 stehen.
Angepasste Formel in D3:
=WENNFEHLER(HYPERLINK("#C"&VERGLEICH(HEUTE();$C$8:$C$33;0);HEUTE());"Datum nicht vorhanden")
Angezeigt wir in D3 "Datum nicht vorhanden"
An welcher Stelle in der geänderten Formel habe ich Fehler gemacht?

Viele Grüße
Heinrich


Angehängte Dateien Thumbnail(s)
   
Antwortento top
#7
Hallo Heinrich,

bei mir funktioniert deine (richtig) angepasste Formel. Auf dem Bildchen kann ich allerdings nicht erkennen, ob deine Daten Zahlen oder Texte sind (was ich vermute).
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#8
Moin Günther,

danke für deine Nachricht.
Das Problem habe ich schon öfter gehört: "Bei allen anderen funktioniert es..." Undecided
Ich habe dann die "Tabelle 1" noch mal in in "Tabelle 2" kopiert. Hier wird keine Fehlermeldung angezeigt
und der Cursor spring an die richtige Stelle.
Der Unterschied zwischen "Tabelle 1" und "Tabelle 2" ist die Formatierung der "Tabelle 1" als Tabelle formatieren.
Ich hänge mal einen Ausschnitt des Aebeitsblattes an.

Viele Grüße
Heinrich


Angehängte Dateien
.xlsb   Sprung zu heute.xlsx.xlsb (Größe: 44,32 KB / Downloads: 2)
Antwortento top
#9
Hallo Heinrich,

überprüfe doch mal, ob du überhaupt das heutige Datum in deiner Liste hast. Ich hab's nicht gefunden - und Excel auch nicht. Wink Mit dem heutigen Datum irgenwo in Spalte C und dem korrigierten Formelteil
Zitat:=WENNFEHLER(HYPERLINK("#C"&VERGLEICH(HEUTE();$C$1:$C$67;0);HEUTE());"Datum nicht vorhanden")
macht der Hyperlink das, was er soll.
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#10
Moin Günther,

hurra, es klappt 28

Danke für deine Mühe.

Es sind die kleinen Dinge, die das Leben schwerer machen....

Viele Grüße und einen schönen Feierabend. Bleib gesund.
Heinrich
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste