Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Mehrere Werte bei gleichem Datum addieren
#1
Hallo,

ich bin neu hier und hoffe auf Eure Hilfe und das sogar noch zeitnah wenn möglich Blush

Es werden mobil eingelesene Zeiten in eine Excel-Tabelle ausgewertet die wie folgt ausschaut:

.xlsx   Test.xlsx (Größe: 13,9 KB / Downloads: 10)


Jetzt habe ich aber das Problem, dass bei unterschiedlichen Stundenarten für einen Tag die Stunden nicht aufaddiert werden was mir keine korrekten Daten in den Zuschlägen ausgibt.
Es sollte also möglich sein der Zelle zu sagen: findest du mehrmals ein gleiches Datum, dann addiere die Werte in Spalte H auf.
In der Tabelle ist noch was verrutscht mit den Wochentagen, der 10.02 ist ein Montag also müssten da noch 8 Sollarbeitsstunden erscheinen ( wie bekomme ich das wieder hin?).

Ich bin für jeden Vorschlag dankbar.
Antwortento top
#2
Hallöchen,

nimm für die Wochentagsermittling das Format 16 (Samstag bis Freitag), dann sollte die Bedingung passen.
Soll die 10,75 dann eigentlich 2x in Spalte H stehen oder wo soll die hin?

Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDEFGHIJKL
1Stundenauswertung
2'Datum''Projekt''Stunden''Mitarbeiter''Stundenart'WochentagRegelstundenerfasste StundenNormalstundenÜstd.Üstd.25%Üstd.50%
303.02.202098_SPARKASSE9,52BLANKArbeit389,528,01,51,520
404.02.202098_SPARKASSE10,97BLANKArbeit4810,978,03,020,97
505.02.202098_SPARKASSE9,73BLANKArbeit589,738,01,71,730
606.02.202098_SPARKASSE11,23BLANKArbeit6811,238,03,221,23
707.02.202098_SPARKASSE10,45BLANKArbeit7810,458,02,520,45
810.02.202098_SPARKASSE7,75BLANKArbeit3810,758,02,820,75
910.02.202098_SPARKASSE3BLANKReisezeit3800,00,000
1062,6548,011,253,4

ZelleFormel
F3=WOCHENTAG([@[''Datum'']];16)
G3=WENN([@Wochentag]<3;0;8)
H3=SUMMENPRODUKT([''Stunden'']*1*([''Datum'']=[@[''Datum'']])*(ZÄHLENWENN($A$3:A3;[@[''Datum'']])=1))
I3=WENN(H3>=G3;G3;H3)
J3=[@[erfasste Stunden]]-[@Normalstunden]
K3=WENN([@Regelstunden]=0;0;WENN([@[Üstd.]]<=2;[@[Üstd.]];2))
L3=WENN([@Regelstunden]=0;[@[erfasste Stunden]];WENN([@[erfasste Stunden]]>10;[@[erfasste Stunden]]-10;0))
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.2) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste