Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Maximalwert je Messstelle oder #NV
#1
Guten Tag zusammen.


Ich habe eine kleines Datenchaos: Es wurde an unterschiedlichen Messstellen zu unterschiedlichen Zeitpunkten der Sauerstoffgehalt gemessen.

Einige Messstellen wurden einmal beprobt andere mehrmals.

Jetzt hätte ich gerne eine Formel, mit der ich die Maximalwerte je Messstelle herausfinde. Das geht mit der Pivottabelle, das weiss ich. Allerdings ist die Tabelle teil einer Datenbank und durch weitere verbindungen ist eine Pivottabelle in dem Fall nicht zielführend.

Kennt jemand die Formel für "Wenn es der Maximalwert der Messstelle XY ist, dann schreib ihn hin, ansonsten schreib #NV"?


Vielen Dank im vorraus!

Monika


Angehängte Dateien
.xlsx   Snippet.xlsx (Größe: 9,25 KB / Downloads: 9)
Antwortento top
#2
(03.04.2019, 14:55)Monika_Kiel schrieb: Das geht mit der Pivottabelle, das weiss ich. Allerdings ist die Tabelle teil einer Datenbank und durch weitere verbindungen ist eine Pivottabelle in dem Fall nicht zielführend.
Ich kann nicht erkennen dass eine Pivot nicht zielführend ist.
Grüsse
Detlef

Bitte keine PN!
Seit Nikolaus 2012 mit Excel 2010. Seit Ostern 2015 mit Office 365
Antwortento top
#3
Hallo Monika,
könntest Du auch mit einer VBA Lösung leben? Dann könnte man sogar den Max Wert auch nur Kennzeichnen.
Gruß Armin
Ich arbeite mit WIN10 64bit und Excel 19 64bit


Antwortento top
#4
(03.04.2019, 15:20)Hydronaut schrieb: Ich kann nicht erkennen dass eine Pivot nicht zielführend ist.

Das lässt sich so auch nicht erkennen. Die (Original-) Datei wird nahezu täglich weiter erweitert, ist deutlich umfangreicher und speist über unterschiedliche Abfrageprotokolle eine Postgres-Datenbank welche wiederum in einem GIS räumlich dargestellt wird. Das ist historisch gewachsen (deshalb leicht kuddelmuddel) allerdings dynamisch was die Erweiterung angeht. Ein neues Tabellenblatt ist aufgrund der eingerichteten Beziehungen, Abfragen und weiterer externer Programmverknüpfungen nicht möglich.

Daher: Gibt es eine solche Formel?
Mit einer entsprechenden Formel könnte ich jederzeit sehen wenn sich irgendwo neue Maximalwerte ergeben.
Antwortento top
#5
Wink 
(03.04.2019, 15:21)EbyAS schrieb: Hallo Monika,
könntest Du auch mit einer VBA Lösung leben? Dann könnte man sogar den Max Wert auch nur Kennzeichnen.

Danke für das Angebot, aber VBA-Skripts darf ich nicht ausführen :/
Antwortento top
#6
Hallo, meinst du so?

PHP-Code:
=WENN(E2=MAX(INDEX($E$2:$E$12*($B$2:$B$12=B2);););E2;"#NV"
Gruß Jörg

"Wer immer tut, was er schon kann, bleibt immer das, was er schon ist." - Henry Ford
Antwortento top
#7
(03.04.2019, 16:01)Jockel schrieb: Hallo, meinst du so?

PHP-Code:
=WENN(E2=MAX(INDEX($E$2:$E$12*($B$2:$B$12=B2);););E2;"#NV"

Vielen Herzlichen Dank!

Ich habe keine Ahnung wie die Formel funktioniert doch sie tut was ich will. Danke Danke!
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste