Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Matrix zuweisen
#1
Hallo zusammen,

ich habe hier ein Sheet mit 2 Spalten (Kategorien), die jeweils low, normal, high sein können. 

Nun möchte ich in der dritten Spalte eine Zuordnung durchführen. 


Dazu habe ich daneben eine Matrix. 

low, low = Zuordnung 1
low, high = Zurodnung 2
usw....


Wie bekomme ich das hin ohne eine kilometerlange Verknüpfung von wenn() ?


.xlsx   Matrix.xlsx (Größe: 11,11 KB / Downloads: 5)
Antwortento top
#2
Hola,

https://www.herber.de/excelformeln/pages...immen.html

Gruß,
steve1da
[-] Folgende(r) 1 Benutzer sagt Danke an steve1da für diesen Beitrag:
  • StrammerMax
Antwortento top
#3
(12.02.2020, 13:36)steve1da schrieb: Hola,

https://www.herber.de/excelformeln/pages...immen.html

Gruß,
steve1da

Die Formel ist sicherlich toll und mag auch funktionieren - aber mit dem dort gezeigten Beispiel bekomme ich sie nicht auf meinen Fall übertragen.
Antwortento top
#4
Hola,

wie sieht denn dein Versuch aus?

Gruß,
steve1da
Antwortento top
#5
So: 
.xlsx   Matrix.xlsx (Größe: 11,62 KB / Downloads: 6)
Antwortento top
#6
Hallo!

Ich habe Steves Formel mal eben selber nachgebaut und sie in deiner Datei angewendet. Da funktioniert sie. Allerdings musst du blank über Wennfehler abfangen.
Code:
=WENNFEHLER(SVERWEIS(C3;$K$4:$O$7;VERGLEICH(D3;$K$4:$O$4;0);FALSCH);SVERWEIS(C3;$K$4:$O$7;VERGLEICH("blank";$K$4:$O$4;0);FALSCH))

Liebe Grüße
Alex
[-] Folgende(r) 1 Benutzer sagt Danke an Oldiefan für diesen Beitrag:
  • StrammerMax
Antwortento top
#7
Hallo ,

ich hab es mit der Index-Formel auch zum laufen gekriegt:

Code:
=INDEX(K$4:O$7;VERGLEICH(C3;K$4:K$7;0);VERGLEICH(D3;K$4:O$4;0))

Bzw in deinem Fall, (da ja einige Felder leer sind):

Code:
=WENNFEHLER(INDEX(K$4:O$7;VERGLEICH(C3;K$4:K$7;0);VERGLEICH(D3;K$4:O$4;0));"")


Gruß
Stefan
[-] Folgende(r) 1 Benutzer sagt Danke an SH95 für diesen Beitrag:
  • StrammerMax
Antwortento top
#8
Top, vielen Dank. 
Sowohl der S-Verweis als auch die Matrixformel funktionieren. 

Allerdings wird der "blank" Fall in dem Zellen leer sind noch nicht richtig abgebildet.

Wenn Kategorie 2 leer ist dann soll nur basieren auf Kategorie 1 der Wert zugeweisen werden. 

Kategorie 1 = low = Zuweisung 1
Kategorie 1 = normal = Zuweisung 2
Kategorie 1 = high = Zuweisung 3
Antwortento top
#9
Hola,

dann setz an Stelle von "" im Wennfehler() Teil eine Sverweis Formel auf Kategorie 1 ein.

Gruß
steve1da
[-] Folgende(r) 1 Benutzer sagt Danke an steve1da für diesen Beitrag:
  • StrammerMax
Antwortento top
#10
(12.02.2020, 13:52)Oldiefan schrieb: Hallo!

Ich habe Steves Formel mal eben selber nachgebaut und sie in deiner Datei angewendet. Da funktioniert sie. Allerdings musst du blank über Wennfehler abfangen.
Code:
=WENNFEHLER(SVERWEIS(C3;$K$4:$O$7;VERGLEICH(D3;$K$4:$O$4;0);FALSCH);SVERWEIS(C3;$K$4:$O$7;VERGLEICH("blank";$K$4:$O$4;0);FALSCH))

Liebe Grüße
Alex

Perfekt - das funktioniert einwandfrei mit leeren ZellenSmile

Vielen Dank an AlleSmile
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste