Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Matrix???
#1
Hallo!
Ich habe eine Tabelle, die wie folgt aufgebaut ist:

art. 1            art. 2           art. 3                    Gesamt
Menge Preis  Menge Preis Menge Preis .... 
1           200                       3       50

Gesamt soll berechnet werden. Die Tabelle hat ca. 50 Zeilen. Ich darf sie nicht umgestalten.
Hat jemand einen Tipp, mit welcher (Matrix?) Funktion man das effizient berechnen kann?

Vielen Dank!
LG Susib
Antwortento top
#2
Hallo Susib,

Zitat:Ich darf sie nicht umgestalten.

wer verbietet das, und warum?
Viele Grüße
Klaus-Dieter
Der Erfolg hat viele Väter, 
der Misserfolg ist ein Waisenkind
Richard Cobden
Antwortento top
#3
Da die Aussage "50 Zeilen" völlig jacke ist, hast Du 50 Spalten, also max. 25 Wertepaare.

AY3: =SUMMENPRODUKT(A3:AW3*B3:AX3*ISTGERADE(SPALTE(B3:AX3)))
Antwortento top
#4
Hi,

reicht dir das nicht?

Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDEFG
1MengePreisMengePreisMengePreisGesamt
222,00 €310,00 €118,00 €87
344,00 €512,00 €220,00 €
416,00 €514,00 €122,00 €
558,00 €216,00 €224,00 €

ZelleFormel
G2=SUMME(B:B)+SUMME(D:D)+SUMME(C:C)
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Günter
Jeder Fehler erscheint unglaublich dumm,
wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#5
(21.05.2019, 17:13)LCohen schrieb: Da die Aussage "50 Zeilen" völlig jacke ist, hast Du 50 Spalten, also max. 25 Wertepaare.

AY3: =SUMMENPRODUKT(A3:AW3*B3:AX3*ISTGERADE(SPALTE(B3:AX3)))

Ich habe ca. 20 Artikel in den Spalten und ca. 50 Zeilen mit Bestellungen.
Die Berechnung mit Summenprodukt funktioniert perfekt. Danke!
Könntest du mir ev. noch sagen, warum und zu welchem Zweck ich hier mit ISTGERADE arbeite?
Die Hilfe zur Funktion hab ich schon gelesen, aber mir fehlt die Idee dazu und ich würd's gerne auch verstehen ;)
Antwortento top
#6
ISTGERADE verwende ich, damit ich die Operation nicht für jede Spalte mache, sondern nur für die geraden. Denn sonst addiere ich auch Preis16*Menge17 hinzu ... willst Du das? Nein.

Bitte keine Widerrede: 50 war völlig überflüssig. Auf die 20 kam es an. Zum Glück habe ich mit meinen 25 nicht zu weit daneben geraten.

Ansonsten hat Klaus-Dieter auch jetzt noch recht.
Antwortento top
#7
Danke an ALLE!
Alles klar jetzt.
LG  19

Ja Wink , Klaus-Dieter hat recht. Ich kann's trotzdem nicht ändern. Sonst würd' ich eine Datenbank draus machen.
Aber jetzt läuft's und ich versteh's und hab wieder was dazugelernt.
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste