Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Markierte zeile in nächstes Blatt kopieren und automatisch zuordnen
#1
Hallo,
ich habe eine Tabelle wo verschiedene Sachen stehen.Diese Tabelle wird immer weiter erweitert.
Nun möchte ich das wenn ich eine Zeile markiere, das nur bestimmte Daten die in der Zeile stehen in die zweite Tabelle eingetragen werden.
Ich bin absoluter Neuling in vba, wer kann mir weiter helfen.
Habe die Datei angehängt.


Angehängte Dateien
.xls   Test.xls (Größe: 132,5 KB / Downloads: 4)
Antwortento top
#2
Hallo

dazu bedarf es kein VBA; Formeln reichen

in D6 : =SVERWEIS($D$4;Tabelle1!$A:$L;2;0)

in D8 : =SVERWEIS($D$4;Tabelle1!$A:$L;3;0)

in D10: =SVERWEIS($D$4;Tabelle1!$A:$L;4;0)

in D12: =SVERWEIS($D$4;Tabelle1!$A:$L;8;0)



in D4 kannst du noch folgendes machen:

- D4 markieren
- Daten, Datentools, Datenüberprüfung
- bei Einstellungen, Zulassen, Liste
- bei Quelle: =Tabelle1!$A$5:$A$900


Jetzt kannst du die Kunden einfach auswählen.


LG UweD
Antwortento top
#3
Hallo,
oder mit VBA. Dazu nur die Zeile in Zelle ab A6...  (Kunde) mit der rechten Maustaste anklicken.


Angehängte Dateien
.xls   Kopie von Test.xls (Größe: 138,5 KB / Downloads: 4)
Grüße aus Nürnberg
Armin
Ich benutze WIN 10 (64bit) und Office 19 (64bit)
Antwortento top
#4
Genial.

Besten dank an euch, ihr habt mir sehr geholfen.
Ich wünsche noch ein schönes Wochenende.

LG Manfred
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste