Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Listen mit Gleichem und Unterschieden vergleichen und abgleichen
#1
Hallo zusammen,

toll, dass es hier dieses Forum gibt! Ich habe eine Excel Problem und da ich mich kaum mit mehr als Standard Sachen auskenne bin ich schnell auf das Forum hier gestossen.
Ich hab auch schon einiges gelesen wie man Listen vergleichen kann, aber komme über das erste Problem nicht hinweg. Ich erzähl mal:

Ich hab 2 Listen die ich per Datenexport csv erhalte (Liste1 und Liste2). Beide beinhalten jeweils eine Produkt ID und einen Preis. Allerdings hat Liste 1 auch Produkt IDs die nicht in Liste 2 vorkommen und umgekehrt ist es auch so. Für mich sind aber nur die Produkte interessant, die in beiden Listen vorkommen. Und von diesen Produkten müsste ich wissen, wenn in einer der beiden Liste ein anderer Preis steht.

Da ich das immer wieder machen muss wäre eine dauerhafte Lösung sehr praktisch. Ich dachte irgendwie an sowas:

1. Ich kopiere die Liste1 in Tab1 und Liste2 in Tab2.
2. In Tab3 soll jetzt eine neue Liste automatisch entstehen mit allen Produkten die in Tab1 und Tab2 vorkommen, dahinter jeweils der Preis aus Tab1 und Tab2
3. Durch bedingte Formatierung seh ich sofort wenn Preis1 nicht gleich Preis2 ist.

Kann mir bitte jemand sagen ob das überhaupt geht und wie ich diese Liste in Tab3 automatisch erstellen lassen kann? Also nur die Produkte mit Preisen anzeigen lassen, die in beiden Listen stehen? Und dann möglichst mit normalen Formeln und nicht Makros da ich Excel auf dem Mac verwende :/

Danke!
Antwortento top
#2

Tabelle3
ABCDEFGHIJ
1IDPreis 1Preis24Hilfsspalten
2110101
3220222
481035
5520204
64106
75645
8
9
10
11
12
13
14
15
16
17

verwendete Formeln
Zelle Formel Bereich N/A
I1=MAX(H:H)
A2:A17=WENN(ZEILE(A1)>MAX(I:I);"";WENN(ZEILE(A1)>MAX(H:H);INDEX(Tabelle2!A:A;VERGLEICH(ZEILE(A1);I:I;0));INDEX(Tabelle1!A:A;VERGLEICH(ZEILE(A1);H:H;0))))
B2:B17=WENNFEHLER(SVERWEIS($A2;Tabelle1!$A:$B;2;0);"")
C2:C17=WENNFEHLER(SVERWEIS($A2;Tabelle2!$A:$B;2;0);"")
H2:H17=WENN(ZÄHLENWENN(Tabelle1!A$2:A2;Tabelle1!A2)=1;MAX(H$1:H1)+1;"")
I2:I17=WENN(UND(ZÄHLENWENN(Tabelle2!A$2:A2;Tabelle2!A2)=1;ZÄHLENWENN(Tabelle1!A:A;Tabelle2!A2)=0);MAX(I$1:I1)+1;"")
http://excel-inn.de/dateien/vba_beispiel..._addin.ziphttp://Hajo-Excel.de/tools.htm
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007 Add-In-Version 21.10 einschl. 64 Bit




Aus... excelformeln.de
Antwortento top
#3
Hallo,

so ganz grob mal mit INDEX/AGGREGAT(). Mehr kann ich dir ohne Kenntnis einer Beispieldatei nicht sagen.
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#4
Cool danke! Probier ich mal aus und melde mich wieder!
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste