Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Listen Vergleich unterschiedliche Mappen
#1
Hallo,

ich habe folgendes Problem.

Ich habe zwei Excel Dateien.

Datei A:
In Excel Datei A ist eine Spalte A mit verschiedenen Nummern zugehörig zur Spalte A ist sind in Spalte B verschiedene Parameter hinterlegt (zu machen Nummern sind aber auch gar keine Parameter hinterlegt, sprich einfach ein leeres Feld).

Datei B:
In Datei B ist eine Spalte C mit Suchkriterien (diese Suchkriterien sind teilweise identisch zu den in Spalte B hinterlegten Parametern).

Nun soll Spalte A nach diesen Parametern durchsucht werden und geschaut werden ob diese sich in Spalte B wiederfinden lassen. Sollten diese dort nicht gefunden werden (entweder weil es den Parameter nicht gibt, oder weil die Zeile leer ist) soll in einer Spalte D die Nummer aus Spalte A ausgegeben werden. Am besten in einer neuen Excel Datei.

Ich hoffe ihr könnt mir behilflich sein.

Grüße


Angehängte Dateien
.xlsx   Beispiel.xlsx (Größe: 9,7 KB / Downloads: 3)
Antwortento top
#2
Moin Marc,

wieso alles in verschiedenen Arbeitsmappen (=Datei), wieso nicht in einer und dort meinetwegen auf verschiedene Tabellenblätter?
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#3
Danke für die Antwort.

Das wäre auch kein Problem.

Grüße
Antwortento top
#4
Hola,

verlinkst du bitte deine Fragen in den verschiedenen Foren gegenseitig?
Danke.

Gruß,
steve1da
Antwortento top
#5
Hi,

mein Vorschlag mit einer Hilfsspalte (farbig markiert), die du einfach ausblenden kannst.

auf Tabellenblatt1

Arbeitsblatt mit dem Namen 'Tabelle1'
AB
1NummerParameter
211433
3142
434622
577719
644322
7234
88674
96745
10568
11475
126784
13478
14894
15879
1667898
1756788
18587
1957812
207648
217568
227488
238
24467
2585
264
276784
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg

Auf Tabellenblatt 2

Arbeitsblatt mit dem Namen 'Tabelle2'
CDE
1Suchparameter#NV in ZeileHS
2332
3223
418
5115
61
747
87
959
1010
11
12
1313
14
1515
1616
1717
1818
1919
2020
2121
2222
2323
2424
25
2626
2727

ZelleFormel
D2=WENNFEHLER(KKLEINSTE(WENN(ISTZAHL(VERGLEICH(Tabelle1!B3;$C$2:$C$9;0));"";ZEILE());ZEILE(A1));"")
E2=WENN(ISTZAHL(VERGLEICH(Tabelle1!B2;$C$2:$C$9;0));"";ZEILE())
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#6
Danke für die Antwort, aber ich glaube wir meinen etwas unterschiedliches.

Bezogen auf die Tabellen in deiner Antwort:


Spalte B aus Tabelle 1 soll nach den Suchparametern aus Tabelle 2 Spalte C durchsucht werden. Wenn der Suchparameter in Spalte B nicht gefunden werden kann (oder dort eine leere Zeile ist), soll mir die Nummer aus Spalte A (Tabelle 1) in einer neuen Spalte ausgegeben werden. 

Grüße
Antwortento top
#7
Hi,

hab' ich es jetzt verstanden? Falls immer noch nicht, wäre eine Beispieltabelle mit händisch eingetragenem Wunschergebnis hilfreich.

Wie gehabt, Hilfsspalte in Tabelle2 einfach ausblenden.

Arbeitsblatt mit dem Namen 'Tabelle1'
AB
1NummerParameter
211433
3142
434622
577719
644322
7234
88674
96745
10568
11475
126784
13478
14894
15879
1667898
1756788
18587
1957812
207648
217568
227488
238
24467
2585
264
276784
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg

Arbeitsblatt mit dem Namen 'Tabelle2'
CDE
1Such-parameterfehlende Werte in Tabelle1HS
233142
3227773
418234
51167455
6156
744787
87879
9567899
10567810
11587
12578
13764813
147568
157415
16816
1746717
18418
19678419
2020
2121
2222
2323
2424
25
2626
2727

ZelleFormel
D2=WENNFEHLER(INDEX(Tabelle1!A:A;KKLEINSTE($E$2:$E$27;ZEILE(A1)));"")
E2=WENN(ISTZAHL(VERGLEICH(Tabelle1!B2;Tabelle1!$H$2:$H$9;0));"";ZEILE())
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#8
Danke für die Antwort.

Das Ergebnis das Du in Spalte "D" bekommst, passt für mich.
Jedoch bin ich anscheinend zu doof, dass auf mein Anwendungsfall zu adaptieren.

Hab mein Anwendungsfall mal angehängt.

Verstehe auch nicht, woher das "H" in der Formel stammt.

=WENN(ISTZAHL(VERGLEICH(Tabelle1!B2;Tabelle1!$H$2:$H$9;0));"";ZEILE())

Edit: So habe nochmal ein bisschen ausprobiert. Tendenziell klappt es, ich habe jedoch das Problem, dass mir in der Hilfstabelle die Zeilen nicht angezeigt werden, die in Spalte "B" in Tabelle 1 leer sind.

Edit: habs dann hinbekommen, dass ich die leeren zeilen automatisch mit einem Leerzeichen gefüllt habe.  Damit gings dann.

Liebe Grüße
Antwortento top
#9
Hi,


Zitat:dass mir in der Hilfstabelle die Zeilen nicht angezeigt werden
das hatte ich auch festgestellt - aktuell versuche ich gerade, die Leerzellen einzubinden. Jetzt binde ich aber erstmal mein Lätzchen um. Angel Wink

So, Marc, jetzt muss ich auch nochmal editieren: du hattest schon bemerkt, dass ich vorhin in deinem Beitrag die extrem kleine Schrift vergrößert habe? Mit deinem Editieren deines Beitrags hast du das wieder zunichte gemacht. Bitte nochmals ändern.
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste