Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Liste erzeugt aus Kombinationsfeldern
#1
Hallo liebe Excel Freunde,

ich möchte eine Liste aus Abschnittsbezeichnungen automatisch ausgeben lassen.
Die Grundlage des Tabelleninhalts sollen frei wählbare Nummern aus Kombi-feldern darstellen.

Wann wählt zuerst die Anzahl an Bauabschnitten 01-10 --- ausgegeben werden Bezeichnungen von A bis J.
Diese Abschnitte sind dann noch in Teilfelder eingeteilt und auch frei wählbar 001-150.

die Zielformel soll eine Liste füllen welche die Teilfelder untereinander in eine Spalte schreibt.
Am Ende eines Bauabschnitts soll der Zähler wieder von "01" beginnen

z.B.:

A001
A002
A003
...
A044
B001
B002

Würde mich sehr über jede Hilfe freuen.
Gruß,
Hannes.
...
B020


Angehängte Dateien
.xlsx   MASTER_test2.xlsx (Größe: 100,53 KB / Downloads: 5)
Antwortento top
#2
Hi

Hier mal eine Möglichkeit.
Code:
____|A|__B_|C|D|E|__________F__________|_______G______|_H_|
   1| |soll| | | |                     |              |   |
   2| |C01 | | | |                     |              |HS |
   3| |C02 | | | |Abschnittsbezeichnung|Teilabschnitte|  0|
   4| |C03 | | | |A                    |              |  0|
   5| |C04 | | | |B                    |              |  0|
   6| |F01 | | | |C                    |             4|  4|
   7| |F02 | | | |D                    |              |  4|
   8| |F03 | | | |E                    |              |  4|
   9| |F04 | | | |F                    |           101|105|
  10| |F05 | | | |G                    |              |105|
  11| |F06 | | | |H                    |              |105|
  12| |F07 | | | |I                    |              |105|
  13| |F08 | | | |J                    |              |105|
  14| |F09 | | | |                     |              |   |
  15| |F10 | | | |                     |              |   |
  16| |F11 | | | |                     |              |   |
  17| |F12 | | | |                     |              |   |
  18| |F13 | | | |                     |              |   |
  19| |F14 | | | |                     |              |   |
Code:
B2    =WENN(MAX($H$3:$H$13)<ZEILE(A1);"";VERWEIS(ZEILE(A1)-1;$H$3:$H$13;$F$4:$F$13)&WENN(LINKS(B1;1)<>VERWEIS(ZEILE(A1)-1;$H$3:$H$13;$F$4:$F$13);"01";TEXT(TEIL(B1;2;10)*1+1;"##00")))
H4    =SUMME($G$4:G4)

Gruß Elex
[-] Folgende(r) 1 Benutzer sagt Danke an Elex für diesen Beitrag:
  • hanso686
Antwortento top
#3
Ich würde gern die Kombifelder beibehalten.
Desweiteren soll die Formeltabelle genau den Inhalt von Soll enthalten, jedoch aber automatisch erzeugt aus den Kontrollfeldern.

Danke für den Denkanstoss.
Antwortento top
#4
Hallo


Zitat:Ich würde gern die Kombifelder beibehalten.
Da sehe ich kein Problem. Der Formel ist es egal ob der Wert in (z.B. Spalte G) von Hand oder durch ein Dropdown eingetragen wird.



Zitat:Desweiteren soll die Formeltabelle genau den Inhalt von Soll enthalten
Verstehe ich nicht. Was passt den nicht am Ergebnis.


Gruß Elex
Antwortento top
#5
Ok ich verstehe die Soll Werte sind die Ist Werte (Formel?).

jetzt verstehe ich abe nicht ganz wie ich die Hilfswerte aus Spalte H in mein horizontales Kombifeld-Layout übertragen kann?.

hast du zufällig eine Beispieltabelle von dem Konzept?
Antwortento top
#6
Hi

Hier mal in deiner Datei.


Angehängte Dateien
.xlsx   MASTER_test2(1).xlsx (Größe: 23,94 KB / Downloads: 4)
[-] Folgende(r) 1 Benutzer sagt Danke an Elex für diesen Beitrag:
  • hanso686
Antwortento top
#7
Danke für diese Formel - das ist sehr hilfreich, Ich werde Mir das Morgen mal genauer anschauen.
Gruß.
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste