Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Liste A Wert abfragen und in Liste B fortlaufend eintragen
#1
Hallo zusammen,

mir raubt die Tabelle langsam mein letzten Nerv. Ich brauche dringend eure Hilfe. 22 


Ziel der Tabelle: Es soll ein Output von Werten geben, die zuvor mit "Ja" in dem Datensatz/Input markiert wurden.

Problem: Ich will das die Werte fortlaufend von oben nach unten übernommen werden ohne Lücken.

Wichtig: In dem Beispiel sind nur wenig Werte angegeben. Die richtige Datei hat knapp 200 Werte und muss noch problemlos erweiterbar sein. D.h. auch, dass die Output Formel problemlos erweiterbar sein müsste.

Excel Version: normalerweise 365       (Vorschau Datei mit Excel 2013 erstellt)

Bild als Vorschau für das Problem:    


Vielen Dank schonmal an alle schlauen Köpfe die hier mitwirken! 23

Gruß,
Markus


Angehängte Dateien
.xlsx   excel problem - liste fortlaufend nach auswahl.xlsx (Größe: 10,15 KB / Downloads: 8)
Antwortento top
#2
Hi Markus,

so:
Arbeitsblatt mit dem Namen 'Tabelle1'
EF
1Nr fortlaufendInhaltsstoff
21Stoff 1
32Stoff 3
43Stoff 4
54Stoff 6
6
7

ZelleFormel
E2=WENN(F2<>"";ZEILE()-1;"")
F2=WENNFEHLER(INDEX(C:C;AGGREGAT(15;6;ZEILE($B$2:$B$7)/($A$2:$A$7="ja");ZEILE(A1)));"")
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
[-] Folgende(r) 1 Benutzer sagt Danke an WillWissen für diesen Beitrag:
  • markus_18561293
Antwortento top
#3
Moin Markus

Mache aus deiner Tabelle eine intelligente Tabelle (STRG-T).
Filtern dann mit den neuen DA-Funktionen.
Code:
=FILTER(Tabelle1[[Nummer]:[Inhaltsstoff]];Tabelle1[Notwendig?]="Ja";"")
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#4
Hallo Günter (WillWissen),



vielen Dank für deine schnelle Antwort und Lösung.


Ich habe das so umgesetzt und es hat alles perfekt geklappt!




Zusätzlich kommt jetzt ein neues Problem auf. Ich will eine zusätzliche Auswahl schaffen. Siehe Datei anbei.




.xlsx   excel problem - liste fortlaufend nach auswahl.xlsx (Größe: 10,5 KB / Downloads: 4)

   





Ist das Problem lösbar oder ist das schon zuviel "Wenn aber hätte können tun"?




Vielen Dank im Voraus!

Beste Grüße,
Markus
Antwortento top
#5
Moin,

nimm einfach einen SVERWEIS().

Arbeitsblatt mit dem Namen 'Tabelle1'
GHI
1Nummer fortlaufendInhaltsstoffVerpackung

Menge (Stk)
21Stoff 110
32Stoff 330
43Stoff 440
54Stoff 660
6
7

ZelleFormel
I2=WENNFEHLER(SVERWEIS(H2;$C$1:$D$7;2;0);"")
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
[-] Folgende(r) 1 Benutzer sagt Danke an WillWissen für diesen Beitrag:
  • markus_18561293
Antwortento top
#6
Hallo Günter,

danke für die Antwort.

Berücksichtigt der Sverweis auch die Auswahl aus I13?
Also wenn ich dort "0" angebe, dass die Menge in I2 10 Stück ist statt 100 Stück (was es bei "1" wäre).

Oder ist das überhaupt machbar?

Vielen Dank im Voraus ;)

MfG Markus
Antwortento top
#7
Hi Markus,

bisher nicht. Aber mit dieser Formel
Code:
=WENNFEHLER(WENN($I$13=0;SVERWEIS(H2;$C$1:$E$7;2;0);SVERWEIS(H2;$C$1:$E$7;3;0));"")

klappt es.
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
[-] Folgende(r) 1 Benutzer sagt Danke an WillWissen für diesen Beitrag:
  • markus_18561293
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste