Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Letztes Komma oder Leer entfernen
#1
Hallo Zusammen,
am Ende einer Zelle kann ein Komma oder ein Leerzeichen sein.
Wie kann ich die beide in einer Formel entfernen?

Beispiel:
Haus Garten,
Garten Hausmann[hier ist ein leer]

Ergebnis sollte herauskommen:
Haus Garten
Garten Hausmann

Vielen Dank!
Antwortento top
#2
Hallöchen,

z.B. =WENN(ODER(RECHTS(A1;1)=" ";RECHTS(A1;1)=",");LINKS(A1;LÄNGE(A1)-1);A1)
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#3
Hallo,

Überzählige Leerzeichen kannst du mit "Glätten" entfernen, Komma mit "wechseln".

z.B.

=GLÄTTEN(WECHSELN(A1;",";""))

Allerdings werden auch überzählige Leerzeichen im Text oder an Anfang entfernt.
Cadmus
Antwortento top
#4
Zitat:Allerdings werden auch überzählige Leerzeichen im Text oder an Anfang entfernt.

... nicht ganz. Leerzeichen vorn und hinten, aber eventuell noch benötigte Kommata auch darin Smile
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#5
(29.08.2020, 12:23)schauan schrieb: z.B. =WENN(ODER(RECHTS(A1;1)=" ";RECHTS(A1;1)=",");LINKS(A1;LÄNGE(A1)-1);A1)

Vielen Dank!

Aber wir müsste die Formel aussehen, falls am Ende ein ", " ist. Also Komma und ein Leerzeichen dahinter.
Wie könnten die 2 Zeichen am Ende entfernt werden?
Antwortento top
#6
Moin!
Mal eine quick&dirty-Krücke:
=LINKS(A1;LÄNGE(A1)-3)&WECHSELN(WECHSELN(RECHTS(A1;3);",";"");" ";"")

Gruß Ralf
Gib einem Mann einen Fisch und du ernährst ihn für einen Tag. 
Lehre einen Mann zu fischen und du ernährst ihn für sein Leben. (Konfuzius)
Antwortento top
#7
Hi Ralf,

hoffentlich wird das vor dem Komma stehende Leerzeichen nicht doch gebraucht. Oder da stehen zwei vor dem Komma, die nicht gebraucht werden Smile Oder hinten stehen mal zwei Kommata ... Oder anders gesagt bzw. den TE gefragt, was in solchen Fällen passieren soll.

ansonsten vielleicht auch das:
=GLÄTTEN(LINKS(A1;VERWEIS(9^9;FINDEN(",";A1;SPALTE(1:1)))-1))
wobei da nicht berücksichtigt wird, dass ein Komme im Text gebraucht werden könnte und ein Fehler entsteht, wenn keins drin ist ... Es wird einfach nach dem letzten abgeschnitten. Da fehlt noch etwas Schmalz in der Umsetzung Smile
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#8
Hallo,

mein Vorschlag: =LINKS(GLÄTTEN(A1);LÄNGE(GLÄTTEN(A1))-1)&RECHTS(GLÄTTEN(A1);RECHTS(GLÄTTEN(A1))<>",")

Gruß Uwe
Antwortento top
#9
Leute, vielen Dank für eure Hilfe!
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste