Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Landnennung aus Vorwahl
#1
Guten Morgen,

ich habe eine umfangreiche Tabelle mit Personendaten inkl. Telefonnummern mit Ländervorwahl (z.B. 1-xxx für USA oder 49-xxx für Deutschland etc.) Die Telefonnumer steht immer in einem Feld nicht getrennt nach Land-Stadt-Nummer, also in der Form 49-221-123456
Ich möchte eine Spalte einfügen, in der automatisch das Land erscheint, welches zu der Landesvorwahl in der Telefonnummernspalte passt.

Ich habe zu dem Zweck bisher ein extra Tabellenblatt erstellt mit einer Spalte Landesvorwahl und einer Spalte Ländername.
Ich habe versucht mir die Lösung des Problems zu ergoogeln, bin aber nicht fündig geworden. Wahrscheinlich auch, weil es nicht ganz einfach ist, diese Problemstellung als Stichworte zutreffend in einer Suche einzugeben.

Kann mir jemand behilflich sein, wie ich das mit einer kopierbaren Formel umsetzen kann, so daß auch neu folgende Datensätze umfasst sind?

Danke im voraus Smile
Antwortento top
#2
Hola,


Code:
=SVERWEIS(LINKS(A1;FINDEN("-";A1)-1)*1;Extratabellenblatt!A:B;2;0)

In A1 steht die Telefonnummer, im Extratabellenblatt in Spalte A die Kennung und in Spalte B das Land.

Gruß,
steve1da
[-] Folgende(r) 1 Benutzer sagt Danke an steve1da für diesen Beitrag:
  • Ankoschei
Antwortento top
#3
man man man...
https://www.ms-office-forum.net/forum/sh...p?t=370667

https://www.clever-excel-forum.de/misc.php?action=help&hid=10
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste